Blizzard Launcher Relaunching

Mac Technical Support
So today I loaded my WoW straight from the 64-bit game file. It prompted me to close the game and download a patch, so I did. The game launcher loaded and began to update the game files. Quick download later the launcher told me I was able to play, so I clicked Play. The 64-bit client started to bounce up and down like it was opening, but then closed ~5 seconds later to open the launcher. The launcher says it is updating game files VERY quickly and then says that I can play. This cycle is never broken.

Please help.
Mac OS X Lion 10.7.5
Bypassing the launcher can always cause problems, which is why we don't recommend opening the game directly, as it is not able to patch properly if the game requires a patch.

Late me ask this. Are you opening the World of Warcraft directly now and see if the patch downloads? Don't open the 64-bit client directly.
I know I don't normally, but for some reason I did today :(

I have tried opening it both ways, same result.
I'm having the same problem.
I usually open gaming directly using World of Warcraft - 64bit.
When I just logged of character and tried switching servers, it kicked me out for a patch update.
However, nothing downloaded as far as I could tell, and now the launcher says the Game is up to date. When I press play though, it just bounces back and forth and ends up back on the launcher.
Clicking on the direct 64bit link again, brings me bouncing back to the WoW Launcher, stating the game is up to date.

Join the Conversation

Return to Forum