Laptop on the fritz

Games, Gaming and Hardware
Alright, long story short, the laptop I usually play WoW on can no longer connect to the internet. (To give some context: I'm currently at college, and my room tends to be a blindspot for wireless, so I use an ethernet cable for a direct connection the school supplies).

This evening, I was forced to manually shut off my computer because Windows had more or less irreversibly frozen up on me. When I turned it back on, I got a prompt (apologies, can't remember what it was) to allow Windows to scan something during the reboot.

Since then, no matter what I've tried after over a dozen restarts, my laptop cannot connect to the internet at all, even with the ethernet plugged in (and yes, I checked to make absolutely certain that it hadn't been the cord falling out of the socket).

Every time I've tried to troubleshoot the problem under the internet access pop-up, I've been told that it can't detect any problems.

I'm honestly at my wit's end here, so I would greatly appreciate any help offered (and answer any questions to the best of my ability).
is your computer recognizing that there is a cable plugged in?
No, it isn't. I've tried restarting without it plugged in at the start, restarting with it then unplugging it for a minute or so, and so on; no matter what I do, it doesn't seem to acknowledge the ethernet.
Here is a link with some information that might be helpful

I'm up to step 3, but I've run into a snag: I honestly don't know what adapter my ethernet is (if any), in regards to the 'uninstall/reinstall' part:

Intel(R) Centrino(R) Advanced-N 6250 AGN
Intel(R) Centrino(R) WiMAX 6250
!Microsoft 6to4 Adapter
!Microsoft Teredo Tunneler Adapter
!Realtek PCIe FE Family Controller

(I've tried updating the driver software three marked with an !, but for Teredo and PCIe it said they already up-to-date, but won't change the status; for 6to4, it can't find the driver software). Any further advice?

Join the Conversation

Return to Forum