outland loading/ ui messed up

Customer Support
i got wow running of a ssd and usually have 5-10 sec loading into zones

tried to load into outlands today and had 3-4 minutes loading and when i got in map wouldnt show neither did the quest dialogs and things kept popping up awkwardly.

relogged and loading was faster but ui is still messed sometimes it shows sometimes it dont.

ive tried deleting the cache/removing addons/disabling antivirus but the problem persists

what gives ? asking around in general seems that alot of people has the same problem. and by the tone in general seems its been going on for quite a while, why isnt it being fixed or even acknowledged ? theres a huge thread over on the EU forums about this but no blue posts
Since 5.0.4, i have seen this happen as well.. when you go into a different zone you havent before (outland, northrend, etc) this came up. Affter a little bit, it did settle down. I actualy had this on my main, in SW, on day one of the patch.. but after an hour, was gone.
yah gonna leave it logged in see if it fixes the problem, corrupted files being redownloaded maybe ?
Not sure if its corrupted files.. or just that they tweeked something on the UI, and its like it has to re download/update or something.

Have you tried running with no addons. I know that i did that durring my time with it.. dont know if it will help, but will iliminate any of them trying to do something with the UI.
yeah tried running a clean client but didnt change anything

Join the Conversation

Return to Forum