[Bug] Killing the Quilen, and Stones of power

Bug Report
I am currently experiencing bugs with the quest "Killing the Quilen" and by default the quest that goes with it "Stones of Power". Neither of these quests are able to be completed by me, it's been this way for 3 days now. I did make a bug report in game.

I was doing the quest, and took an instance que. Upon returning from the que the Quilen were no longer there, and the stones of power were gone. I tried restarting, leaving the area, going into a que to try to force a phase shift nothing.

On another note, My character is "phased out" in general to any alliance or horde, I only see npc's and when grouped with a party i am the only one that appears phased out.

None of this happened until the two quests bugged out, I believe these are important to open up dailies. Can anyone help? :(
No one else is having this issue?
stuck at stones of power quest. it seems im phased out as well.
Mines doing the same thing on my main. I've put in 2 reports and it is still not fixed. It's been 5 days. This is a huge issue because you cannot start Golden Lotus Rep grind dailies until this quest is completed. Yet again, Blizzard phasing fail.
doing the same for me.. no stone guardian to kill
It won't fix the problem, but I did find the quilen gurds you need by going into the temple. There are two stone guards who stand at either side of the table in the center of the room, and they respawn instantly, so you can get that one done. Still haven't found the stones though. It's be going on for about a week now. :(

Join the Conversation

Return to Forum