having major issues with macros...

UI and Macro
for whatever reason a lot of my macros are not working anymore. I tried making a real simple one to heal my arena partner:

/cast [target=name] healing touch

it keeps giving me an error saying "unknown macro function: target=name"

I never had any issues in the past with these and i dont know if something changed, anyone know what im doing wrong?
Copy/paste the macro. I suspect a typo.
here are 2 of the simple ones that wont work:

/cast [target=name] healing touch


/cast [target=focus] cyclone
don't feel bad. my mount macro that says /cast [swimming]Aquatic Form will no longer cast AQUATIC form because you "can't do that while swimming"...

I suspect you aren't crazy, and that something is off in macro land.
Just a thought - have you tried using @name instead?
Just a thought: Are you typing in [target=name] or are you typing the name of the person you are trying to target instead. So,

/cast [target=Doroteasenjk] healing touch

is the way you might write it?
Another option would be to use @party1 (or @party2 through @party4 if you're talking about 3s or 5s) instead.

Note that @name/target=name will only work if they're actually in a party/raid with you (even if it's not a party/raid-only spell).

Join the Conversation

Return to Forum