[Quest] Battle Helm of the Thunder King

Bug Report
1 2 3 25 Next
Clicked the NPC and followed him to where the helm sits there shining in a beam of light however it is not interactable and nothing else spawns or happens in the area. I read there is supposed to be an NPC to kill but he does not spawn, and the friendly NPC simply despawns.
This is a known issue, but blizzard has not replied to anyone who has reported it as of yet. There is a work around. You can do a cross realm invite with someone who is lv90 and it should allow you to interact with the quest as intended. However, this is really annoying if you do not know other people that are lv90 on another server....
Same issue ... A bunch of us were together and having an issue with and the kill Bloodtip quest. Ugh!
Got it working, thanks for the invites all
Zel, I sent u a request
Can anyone help me out as well? Tag is Paradisio#1896
10/10/2012 03:15 AMPosted by Rokuris
Zel, I sent u a request

I didn't get it? I got Paradisio's but the whole horde/ally thing doesn't work well with parties lol
Well Zel and I did try ... and no luck for either realm.
Tried with multiple people with no luck, doesnt help that the tiles in the hall of tiles kill me even when I step on the right ones and follow the NPC -_-
Same issue, when he says "ugly" he despawns, nothing happens, cant click on helm. Tried realid crz invite, didn't work.
Attempting this quest also wiped out my pet battle achievement progress. Fun!
This is starting to become a bit frustrating :( Bugged on Lightning's Blade too
also bugged for me to on Icecrown. Blizz please fix this!!!
or can we at least get a blue post letting us know this is being worked on? it sucks for us who worked so hard to get revered with this terribly long grind only to hit a stop.
If any one knows some one on a server where this still works can you have them add me Derby #1780 this quest is causing a issue with me completing the daily to get the treasures of the vale today also
"HE's SO UGLY" Gametris#1955 I'm having the same issues as Derbymchat
still bugged
EDIT: Bugged for my server, not one person I've invited has been able to complete the quest while in my group.

Found someone on a server that wasn't bugged. In my case Bloodscalp worked. The one who invited me was having his own issues with the quest, but it worked for me when I phased over.
"Working as intended"?
As soon as I walked in and couldn't click on the helmet I kinda knew it was a bug and came straight here.

Join the Conversation

Return to Forum