Digital Copy FAIL

Customer Support
Bought a card from game stop for Pandaria. The code from my receipt doesn't seem to be working. I'm using the chain of letters and numbers indicated as the activation code on the receipt. Perhaps I'm going to the wrong area of battle.net to activate? Any suggestions and/or assistance would be appreciated.

About to just to back to the dang store and tell them I want my money back.
The message I receive is this:

The code you entered cannot be claimed. Please check the code and try again. If you see this error again, please try again later, as the game or website may be undergoing maintenance.

I've entered the code using the same caps, dashes, lower case, minus dashes. Every possible way to enter the digits has been tried. Getting quite frustrated.

*BTW, I'm entering this data into the text field available at battle.net/code
Try a different type of browser.
I've attempted it using both firefox and ie. Same idiocy with both browsers.
I cleared history/cookies on firefox, and tried again. Worked this time. No idea what the problem was.
I would suggest opening up a support ticket and including a picture of the code that you have. I know you say you entered it every type of way but some of the numbers and letters are easy to mistake so double check and make sure (I am sure you already have) but all I can say is try again after submitting your support ticket.
Good I am happy that you were able to get your problem fixed.. I know how bad it sucks to want to play and not be able to.

Join the Conversation

Return to Forum