Dark iron ore smelting quest glitched

Bug Report
I have been at this for over A WEEK now. i have submitted tickets and GMs send me mail saying Blizz dont give hints talk to ppl and research on wow friendly sites.

i have done this and it doesnt work. i went to BRD to speak to gloom'rel. after speaking to him the quest The Spectral Chalice appears next to him. i picked up the quest and turned in the required items. after completion of this according to all sites and people i have spoken to I should have the ability.

I have not recieved the ability and i have been going to the roght spot to try and smelt.

if anyone can help it would be great.
http://www.wowhead.com/spell=14891#comments
From a similar thread a few days ago:
10/12/2012 03:08 PMPosted by Vrakthris
Our QA teams are looking into it, and our Devs will determine what can be done to fix it. Once it has been verified specific procedures should come about to address those impacted. Though I suspect the NPC will just be fixed so you can learn it from him.
10/17/2012 02:55 PMPosted by Flatspriest
http://www.wowhead.com/spell=14891#comments


done all that
Here is the CS link from a few days ago.

http://us.battle.net/wow/en/forum/topic/6794732181

I would also suggest posting on the Bug Report forum to ensure your experience is added to the list.
Ran into this on my miner. What I did was talk to Gloomrel, turned in the gems/bars but didnt talk to him after. Then I did the fight without having talked to him a second time. Afterwards I didnt have the smelt dark iron skill.

However now that I have completed the task, there is no way to go back and redo it to learn the dark iron smelting.
This is still bugged tried to learn it other day , pay tribute but he doesn't teach you how to smelt this used to work cause i had it on my pally at some stage before i dropped the profession still had to pay tribute again.
I did this quest for the first time tonight. Talked to Gloom'rel, got the quest from the chalice, completed it, talked to Gloom'rel, he did not teach me Smelt Dark Iron. This quest is undeniably broken.
Actually just recieved a response from another GM. Fix is slated for patch 5.1. Fair enough.
I can confirm this bug as well. Opened a ticket, but was only given a generic "please post in bug forums" response.
Hopefully the response that Zanmaru received is correct and we will see it fixed in 5.1
Confirmed that it is still bugged today at 10/23/12. I read through the patch notes for 5.1 and I didn't see a confirmation that it was going to be fixed =/
The promise was to fix it with 5.1.... yet 5.1 notes and 5.1 Hot Fix notes have posted with nothing in them, and the quest is in fact still not working.

How they managed to break something that has worked fine for so long, and do it with a completely unrelated xPac some 40 levels beyond that place.

Blizzarre!!!!
I had the same problem but I just went to BRD again and glom'rel finally gave me the chat option that taught me the skill.

I confirm that as of 12/12/12 in patch 5.1.0a the quest is working again (you do not need to turn in materials again if you had already completed the quest)

Join the Conversation

Return to Forum