Guild Chat Not Working on specific realms

Mobile Bug Report
Since this threat is updated recently I'll continue it. I just got mobile armory yesterday and trying to log in.

Everything works but G/chat i can't log into, says cannot log into server.

< this toon & guild -Thorium Brotherhood. No recent changes to character or guild.

Using HTC Prism, android, 3G.

Just tried a character on another server (Silver Hand, The Lost Ones, Nebi) still cannot connect.
I'm on Khaz Modan, and the guild chat won't connect for me either. This has been happening since yesterday. I'm using an IPhone 4, with newly upgraded to iOS 6.1 or whatever the new one is...i know it's 6.x tho.


Still not able to connect on Hyjal remotely. I have deleted and reinstalled the app on my iphone twice. Any word on timeline of resolution would be appreciated.

Thank you
Hi im on blackrock and this started happening to me tonight i thought it was somthing i must of done but ive checked all chat setting they ok.... i cant see what i type in guild chat or anything anyone else types they can see what i type thou i can log on to alt and guild chat works fine .
Can use everything else like the auction house but can't connect to my guild chat, Draka server.
Same. Cho'gal.
I cant log on chat either but it was working a couple days ago. It says connection timed out.
It isnt working on my priest as well who did just recently join a guild but was working fine on saturday
Guild: Scalebane
Realm: Eredar (US)
Character: Jolipapillon
Phone: iPhone 4, iOS 6.0.1
Armory Version 5.1.0

I can't even log into the app right now. But for the past 2 days, if I get in I can't get to Guild chat.

'Login Failed
Unable to establish connection to server.'

Please fix, Blizz! <3
My armory guild chat has not been working either. On either of my realms, on any of my guilds, and I am in a few of them. Nothing has changed with any of my guilds or characters or account.
I'm noticing the same effect on my android also, and as i have read earlier, i wanted to ask could it be caused by having a neutral rank within your guild? i just joined a new guild today and was using the app to do work in the auction house but i couldn't even use or look into my guild roster.

Curiosity has gotten the best of me and i'm wondering if my new recruitment into my guild would cause this problem?
Yes, this is a known caching issue. It can take some time before this updates. If this hasn't already started working, it should work after Tuesday maintenance. Let me know if it doesn't clear up.
6/12/2015. This is still happening.

Usually /1. But today, /g.
/1 requires loading a backup of chat-cache.txt .
for /g, I replaced my chat-cache.txt with a backup, didn't work.
Later, it seemed to work again after a client restart.
4/26/2016 if anyone is watching this is still an issue at least on stormrage and proudmoore.

On stormrage i have a dwarf warrior who can log in with no issue at all and chat with no issues. My dwarf paladin is in a guild but is not given an option to choose guild chat. Treated as though he isnt in a guild. Was tranfered recently.

My orc warrior on proudmoore is in a guild and i can sse the guild but when i try to chat, i am prompted to log in and this takes a while and fails everytime. I can see the guild name and symbol though.

My dwarf warrior works everytime.

Join the Conversation

Return to Forum