Launcher Stuck On Initializing..

Mac Technical Support
Well, sometimes dreams do come true..., erm I mean yay! Make sure the launcher says the game is 100% complete to ensure that all components are up to date :)
Hey Mach,
the problems back again lol. VERY odd! Any advise?

Can you try creating a new admin user account and log into that account and see if the same issue occurs?
Will try, give me a sec.
Still the same issue with a new login as administrator
Something is preventing the launcher from connecting properly :(

Do you have any security apps, firewalls, or web filters enabled on your Mac?
I had Symantec End protection, but it as been working well for the last 8 months without any issues.Just very odd that it started last night with no changes. I uninstalled Symantec totally, and I even downloaded a new setuposx.mpq from gamefront and used that to launch the launcher but no use. It randomly will start up for some reason, but then will not work other times.
hey Mach,
i have used symantec end protection for the last 8 months with no issues, they only started last night out of the blue. I do not have any other security apps. I uninstalled SEP now totally now, but still no resolution completely only random connections. I also downloaded a new setuposx.mpq from gamefront and tried using that as per an mvp user on the windows forums but still not 100% successful. It is very odd that it will connect randomly sometimes but then refuse to work.

When it is on "Initializing, please wait..."; Agent has launched the Blizzard launcher, is checking permissions and looking for new data. The only other thing I can think of is perhaps it is not getting information it needs sometimes.

Can you try flushing your DNS?
Mach, that did it !!! =) At least its workin for now lol
Thank you for all your help!
Have a great weekend :)
Awesome! I'll have to add that to our list of solutions for that. Thanks for confirming! Let me know if there is anything else I can do for you.
Hey Mach,
I am back with the same issue....... I am doctor at clinic and we use Citrix as a platform for our EMR. In my activity monitor I have an app called Citrix Service Record Application that refuses to quit. I was wondering if using Citrix is whats causing the WoW launcher to have issues, as I think anytime I force quit the citrix application WoW possibly starts up. But the thing is the application comes back to the activity monitor. Any thoughts???
That might be it, as it makes sense. When you reset the DNS cache, you killed the DNSresponder which basically reset the connection and allowed the Launcher to connect during that downtime. If it is just the launcher doing it, you can try to bypass it for now, and open World of of and see if it allows you to run it directly. The only issue will be when it comes to patch, you will need to run the launcher.

I don't know too much about the Citrix app, but if you disable it and it comes back on, this means another Citrix process is open that requires it to run. If you see any other Citrix processes (some may not have an app icon by it), those might be keeping the app open and running. I would contact your network admin to see if it is safe to kill those processes or to help with configuration of the program to your Mac.
There's possibly a LaunchAgent or LaunchDaemon with a keep alive parameter bringing it back up again.

What's EMR ? I'm worried that if you fool too much with the Citrix then you may break something that's meant for work and it could affect your work.
im having the same issue but it seems that the updater isn't even downloading the patch
You'll want to create a new thread Drenix, as this issue was relating to Citrix. Unless you have this app installed, then it isn't the same issue.
I am currently having this issue on my PC that is running Windows 7 x64. I haven't just let it sit for long periods of time because I have been using this laptop to take notes in school, and I am not wanting to waste my cell data usage to download this game again. Anyone find anything else other than leaving it for long periods of time?
Heres my system info:

Still having the stuck on initializing problem :(

Model Name: MacBook Pro
Model Identifier: MacBookPro8,3
Processor Name: Intel Core i7
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.70f5
Hardware UUID: E6840CF0-CAC3-55EF-B7B1-8A35B7008681
Sudden Motion Sensor:
State: Enabled

Chipset Model: AMD Radeon HD 6770M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6740
Revision ID: 0x0000
ROM Revision: 113-C0170L-573
gMux Version: 1.9.24
EFI Driver Version: 01.00.573
Color LCD:
Display Type: LCD
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Version: Mac OS X 10.7.5 (11G63b)
Kernel Version: Darwin 11.4.2
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 10 days 11:33
Same issue on my Wife's Win7 machine but not on my Win8 machine. I tried all the steps listed but did not have any success to get the launcher to run. Any other suggestions, patching options?
Windows users will need to post in the Windows Technical Support forums:

Anything posted in this forum will be Mac specific.

Join the Conversation

Return to Forum