Remote armory error

Mobile Bug Report
Again the remote AH is crapping out an armory error. Using iPhone 4 on ios6 updated app. Guild chat seems to sign in fine, but when I load the AH it craps the error and sends me back.

Nice that last night I couldn't login to the game and this morning I can't get in to manage my auctions.
Is this still an issue for you?
Yes this is still an issue. The AH says that the realm is down for maintenance while the realm is actually up.

Shadowsong server reporting in.
Yes this is still an issue. The AH says that the realm is down for maintenance while the realm is actually up.

Shadowsong server reporting in.


Not quite the same issue. Today we are experiencing post-maintenance issues with Guild Chat, Auction House, and some other areas of the app that pull data from the game server. Engineers are working on this now.
My issue is that on my galaxy S3 phone and i can't connect to mobile armory while i'm connected to a WiFi netwok, whenever i try it says: Too many atempts. The weird thing is that when i'm connected to the cellular network it works fine, i only have problem when i'm connected to WiFi. And it's not just my home WiFi connection, any WiFi network i connect my phone with i can't log in into the mobile wow armory on my phone.
11/11/2012 01:49 PMPosted by Oxyo
My issue is that on my galaxy S3 phone and i can't connect to mobile armory while i'm connected to a WiFi netwok, whenever i try it says: Too many atempts. The weird thing is that when i'm connected to the cellular network it works fine, i only have problem when i'm connected to WiFi. And it's not just my home WiFi connection, any WiFi network i connect my phone with i can't log in into the mobile wow armory on my phone.


Thanks for the heads up. We'll take a look at this for you.
I am getting an error message saying: error.armory-error message when trying to access guild chat.

Using iPhone4 with ioS 6.0 on AT&T 3G network
I am getting an error message saying: error.armory-error message when trying to access guild chat.

Using iPhone4 with ioS 6.0 on AT&T 3G network


Same but I tried both Wi-Fi and 3G. Same result.
Same here cant chat. BLIZZ we aint winnin!!!
I am using a samsung galaxy II 4g with not only an issue accessing part of the Armory, I can not access all the armory. I have tried un-installing and re-installing it and still does not work.

Join the Conversation

Return to Forum