Windows 8 and can't use my add-ons, help!

Technical Support
I just recently got a brand new gaming computer and it has windows 8 installed, it's the hp envy m6, now I can play wow fine without using add-ons but when I go to enable them I get stuck about 1/4 the way loading into the game and then wow says not responding and stays like that. If there is anyway I can fix this so I can use my add-ons again I would love that. I do have the curse client and never had this problem before on windows 7. Please Help!
Windows 8 isn't supported by Blizzard. Using WoW on Windows 8 is at your own risk :/

If you still can, boot in Windows xp/vista/7 instead for playing WoW.
Windows 8 isn't supported by Blizzard. Using WoW on Windows 8 is at your own risk :/

If you still can, boot in Windows xp/vista/7 instead for playing WoW.

Not true and HP wont offer support or provide drivers for Windows 7 on Windows 8 machines.

Have you tried disabling some addons to see if its a specific addon that's causing the issue? Also, did you copy the WTF folder from your previous install? (Old/bad addon settings may cause this)

You should also try disabling Curse client temporarily.
I just made a Windows 8 VM and copied my hole WoW folder over.
It started fine with my addons and settings.
Yes I have, it is all my addons that are doing it. So It has to be something with the windows 8 idk though... :(
I just made a Windows 8 VM and copied my hole WoW folder over.
It started fine with my addons and settings.

I'll try taking it to Best Buy or something and see if they can copy all my files onto a hard drive and transfer it over, if not then well, guess I'm !@#$ out of luck?
The addon Cartographer gave me this issue when I came back from not playing. Disabling fixed the issue for me, I haven't had the need to reinstall it, so unsure on it's status now.
same here sadly cant see any of my addons in my screen ;/ oh well guess im gonna have to play the game, the way it was meant to be!
When I transferred everything over from my Windows 7 to Windows 8, my WoW folders got shuffled and mixed up. I just did a search for it in my C drive, found it and re-downloaded my addons and replaced them in the folder's new "home". That seemed to work okay.
OK to get addons to work on windows eight is weird. Wow has to be run in administration mode, which means it needs administration privileges. Also once you do get them unzipped you have to take them out of the folder and move them up one folder into your addon folder to get them to work. In other words when you get the dbm folder in there, you have to pull the folders out of that folder and move them up one folder directly into the addon folder itself if they are not already there. It is a pain but seems to work on all the ones I have tried so far. If you find out anything different, let me know.
Its been 4 months since the last post, and wish I had read this before buying the gaming computer with Windows8... are there any new developments? Has Windows and Blizzard come to any arrangements that will allow me to install my addons without the Cecil B. DeMille productions offered above?
Zareena,

There's really nothing special that has to be done for addons to work under Windows 8. They work the same for any version of Windows that's supported. Just make sure the addon folder containing the actual files for the addon is in your Interface\Addons folder. The most common mistake people make is to put the addon folder they've unzipped after downloading there but that folder usually contains another folder with the addon files. That's the folder that has to be moved, not the first one.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
I have windows 8.1 and use the Curse client and have no issues with addons at all.
I just installed WoW on my new PC (Windows 8.1) and no interface folder exists (I did make sure all files and folders were showing). All I have is a file called interface.MPQ
I don't have the add on tab at login anymore with my windows 8.1. The one where you select what character gets what add on etc. anyone else have this problem?
Asgear,

This pretty much means you don't have any valid addons in the proper location. Did you follow the advice I gave in my post above?

Can you list the name of one of the addon folders you have in your World of Warcraft\Interface\Addons folder? Don't list a Blizzard folder, just list one that you've added.

_________________________________________________________
I'm available in the forums Monday - Friday, 11 am - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Omrakos,

Okay so ive found the interface/addon folders however I don't have any zipped files... when I open them there are a few things in each including two other folders titled "libs" and "support" , so from what I understand I have to pull files directly out of the first file I go into itself for the addon, so which ones do I pull out and copy directly into the addon folder?
oh the addons I have include

bagon
sexy map
recount
dbm
bartender4
atlasloot
auctionator
gathermate2
omen
player score
reforge lite
npc scan
npc overlay
Nvm looks like I just needed to restart my computer , logging in and out of game last night wasn't enough thanks for all ur help tho
I have been playing WoW since inception so I am used to all the hangups. However I have to tell you the Windows 8 thing has me stumped. I have attempted to strip out my WTF, had manually moved the zip to the interface/addons folder and then extracted there, have deleted the zip files after extraction, have even extracted outside of WoW folders and manually moved the addons over. Nothing is working. The default addons for WoW barely work.

My question is is there something in the administrative mode that needs to be altered in order to have the addons recognized by the individual account possibly? Do I have to give my account rights to play WoW addons from the administrative mode?

Help Obi Kynlata you are my only hope!

Join the Conversation

Return to Forum