Mobile Armory - Connection Error

Mobile Bug Report
The mobile armory app has been working very slow today, and now I get a connection error when I try to login. Is the service down?
Hi, i have a problem too with the connection. the last week the armory mobile told me that one port had been blocked I fixed the problem openning the ports on my INTERNET SERVICE PROVIDER MODEM but today my ISP delete my configuration, the BIG TROUBLE now is "that i dont remember which port is blocked :( "
So if someone knows the port number and for the armory app i will be gratefull.
Maybe, Sorry for my mistakes writing in english.
Having the same problem :( can't log in to the chat.
Not working .. Cannot connect iPhone 4 ios6.1 wifi connection
Having connection errors on my Samsung gallery s 3, can't even log in.
Get connected to main screen of the app after a couple of tries, but will not log in to auction house, guild chat, or allow me to see who's online. Moto Droid
Chat will not load, but everything seems to work
Now it is only the chat feature that will not work. Unable to establish connection. Problems on 3 different WiFi connections and 4g.
I couldn't connect to the armory via 3G either. :(
chat has been down and spotty for about 16 hours.
As soon as I get this app I can't use it =.=

Edit: Well.... The chat part at least.
Agreed. Same issue.
Been unable to, for the most part, log into chat. I'm lucky to even be able to log into the app at all. The two times over the last 4 days I've managed to, it's felt like winning the lottery.

I've had a multitude of problems with this app. 4 days ago when it started, it was the port blocked error. I tried connecting on three different WiFis all with the same error (probably not WiFi). When I turn off WiFi and try to connect via 3G, I get the connection timed out error, or it loads so long I give up and exit out of the app.

The past couple of days it's been foreverloading each time I try to sign on. I'm pretty glad they made this app free because I'd be one irate customer if I was paying for nothing but wasted time and connection errors.

Please fix this, or at least address the issue and say what you are doing to try to fix it. All I've seen is an employee saying this is a WiFi problem and not an app problem. Again, I am not tech savvy but it seems unlikely so many different people suddenly have faulty router/modems at once, yanno?

4 days of frustration with this thing.
I've been having problems with the app for the past week (or more) and they all line up to about the same issues in this thread. Today it's functionality has been intermittent, but down about 90% of the time I've tried to use it.

I'd say all in all in the past week and a half, it's been down 60% of the time AT LEAST. What's the deal? I mean I change no settings, try to log in, doesn't connect, 1 hour later its fine, the next hour its not. I don't understand.

edit: ios 6.0.1, 4s
Since the last update to the mobile armory on my iPhone I haven't been able to log in at all. Every time I try I get an unable to establish connection error.
Been having tons of issues, on an off, with this apps connectivity since the last patch (and since iOS 6)
But, the last several days has been excruciatingly painful lol. Getting connection issues while trying to use guild chat and mobile auction house. Wifi blocked errors while on cellular. I can log into the app itself and look at my characters... That's about all that works reliably.
Having same problem with guild chat on iPhone 4S. Everything else seems to be working.
Yes I have been having these issues all week as well. Sometimes I can log in to the app, sometimes I can't. If I do get to log in then it will not let me connect to guild chat.
Still having problems since yesterday.
Same issue - Samsung Galaxy Note II - Jellybean.

Join the Conversation

Return to Forum