Mobile armory "Login Failed"

Customer Support
As of today i have been having a problem with the mobile armory. It started with just a few problems of not being able to sign into my guild chat while at work but now i cant even sign into the Mobile Armory at all was just wondering if this is just a "for me" problem or ifs its happening to a lot of people today.

Mobile App. is up to date
Happening on and off of my home network
Having the same problem here
Happening to me too. Worked for maybe 20 mins then got slow, and now I can't even log in. Been flaky all week actually. I wish there were updates about mobile armory downtime too, but that's less critical I suppose. Especially now that it's free.
Having the same problem here. It's been happening for me for a while now, and it's gotten to the point I can only log in very infrequently.
I am having this same issue. for the first week, It let me log into the app, look at my characters and such. But, as soon as I attempt to use guild chat, or the mobile auction house, it says unable to connect to network. I even got the wifi blocking error while on cellular. Now, I have almost no functionality at all. Tried logging into several different character, on different realms and factions. Same issues on wifi and cellular.
yep mine is saying that my wifi may not be allowing the port 8780 through i guess i could port forward it but it just seems a waste of time since i cant even connect when i just run on the 3g
I've had this issue as well since yesterday. Frequent failed or prolonged login attempts over cellular or wireless. Occasionally able to get connected initially, then complete failure since last night. Using iPhone mobile armory app.
Me too!
Me 3 :(
This is why the Mobile Armory is fully free now. It doesn't work well at all - and some realms have basically never worked (Moon Guard, I'm looking at you.)

The support for this app was never through Blizzard, but a 3rd party, and that 3rd party was never able to actually fix the all ready existing problems. Due to many months of inaccessibility to so many realms, the app went free. But also, the level of support dropped even more, it seems.
My app too is also not working, and I had made a previous post on this same problem last week that a GM responded too, problem got fixed, then by thursday was broken again. Would love to see resolution on this..also to the guy on it being a third party problem and since its free its not blizzs problem..if you wrap cat crap in a box, then slap your businesses name on it, guess what? Its your problem to deal with whether ya like it or not...
@Kreider My experience has been different. I've found it to be a tremendous aid in managing my auctions. Good feature set, automatically syncs with authenticater app, searching character and item info fast. Given spotty cell coverage sometimes, I'm surprised I haven't lost an auction or gold at times. Perhaps it has functioned better with my realms, but I can't imagine playing the ah without it now. YMMV *shrug*
was having the same problem until i updated just now.. try doing the same.
My app is totally updated and its dead in the water. I am intermittently able to log in and view AH and characters. But I haven't been able to connect to anything guild related in a couple days.
I haven't been able to access the mobile AH for 4 days now... really dissapointing that there's ZERO response from Blizz.
Thought it was just my sketchy network! I've been having a lot of problems in the past couple of days too.
There is a mobile bug forum. Please post there.

Join the Conversation

Return to Forum