Domination Point Cutscene Missing/Phase Issue

Bug Report
The cutscene that's supposed to play upon completion of the Domination Point quest is currently missing or bugged. Additionally, you're supposed to be put in a new phase upon completing the quest but that doesn't happen until relogging.
i got disconnected after relogging ALL the time, do you face similar issue?
Same thing happened here, but after about 5 minutes of standing around everything popped and I'm standing in the middle of a horde bloodbath and have no idea what I missed or where I'm supposed to go. Mustve missed part of a chain.
On my shaman, when I did the "light the fire" quest, I got the cut scene and got ported to the keep and saw the conversation between Garrosh and Vol'jin.

When I did the same thing on my monk, no cut scene, nothing. I had to fly out of the area and fly back, then I was put into the right phase. I missed out on the Garrosh/Vol'jin convo, but I didn't miss any quests (everything works properly from this point).

A friend of mine just did it, no cut scene. It seems to be buggy, but intermittent (it does work sometimes as I can testify).
On my Hunter, the same as those above ..clicked the signal fire on the beach ..nothing happened, no cut scene, no further quests, no nothing..did the Ally one earlier, that went through just fine..

Tried relogging, reappeared on the beach with domination Point keep up and running and all the alliance players and npc's running around, no Garrosh, no anyone, no quest in book to carry on etc.

tried going back to shrine, relogging again ..flew back to Dom Point ..still nothing, zip, zero ..assume this is being looked into as this is rather integral to the story, and to getting I believe the starter quest to do the Horde-side Scenario as well...never mind the new dailies etc

thanks in advance for sorting it all out ../grin
When I lit the signal fire, the quest completed and nothing happened. When I flew out of the subzone and back again I was put into the correct phase. However I did not see the cutscene of the horde landing neither did I get to see the Garrosh-Voljin meeting. However General Nazgrim did give me the quest for dagger in the dark.

Feels frustrating when even the tiny crumbs of lore that was included in this patch was made unavailable due to a bug. Isn't the point of the PTR to catch and fix this sort of thing?
Same issue as what has bee posted above in regard to the cut scene. Turn in the quest, no cut scene. Screen goes dark like it's going to start, then goes back to normal. I logged out and back in at the spot where I turned in the quest. Saw the correctly phased area, and then I fell through the ground to my death somehow. Not pleasant. Disappointed I had to go look up the scene on Youtube.

For anyone who was unable to view the scene and would like to, link is here: http://youtu.be/FPOiIdqf8Eo
This happened to me last night as well. I found this thread and just wanted to pop in to let you know we're working on a fix this asap for players who haven't done it yet.

I know personally what it felt like to miss the transition and following Vol'jin/Garrosh conversation, so I apologize to those who experienced it as well.
THIS IS AN OUTRAGE! RAGE! RAGE!

what we talkin aboot?
On the Alliance side, after doing the intro quests with Varian, once I got back to Lion's Landing Admiral Taylor had a quest for me. I relogged so I could set my addons to "use out-of-date addons" (not realizing that changed the phase since there was no warning---and why can't WoW remember this setting from one patch to another?) and I was in a new phase with no quest from Admiral Taylor, who was now in a different place. What did I miss?
I had this problem too. I finished the signal fire quest, and nothing happened. I relogged, and came back into the game falling through the world and died. Rezzed at the GY, and I was in the correct phase, but never got to see the cutscene.
Sooo, can I request that my character be re-phased to before I did these quests, so I can do them once its working? Or am I just screwed out of content now?
Aha! So it wasn't me being high on something I didn't remember ingesting!

I completed the "Light the fire" quest, expected a cutscene and some fireworks but nothing happened. I stood beside Garrosh waiting for him to do something, but he ignored me.

So I thought perhaps something happened at one of the other sites. Flew around, no different from before.

Then there was a rolling restart and when I relog'd, I found myself in limbo, deep inside the ground under some building I think and slowly watched my health dwindle till I died.

When I res'd and walked back, the whole town was now there. WHUT?

I expect this to be what coma patients experience after a few years in deep sleep and then rudely awakened again.

And now you guys are saying there's some epic cutscene where Vol'jin kicked Garrosh in the nuts (or something)? Can I be reset back to the lighting quest please?
They'd better, I kept my subscription going to see this huge reveal.
I too crashed during the cutscene after summoning the fleet. When I returned I was falling through the world and got booted. Relogged again and got put back on dry land but have no idea what I am supposed to do now - I think I missed part of the chain. /sad!!!!
Happened to me too. Just stood there till I flew around and found the quest givers in the new fortress. I only figured out the cutscene when I did my Alliance PC and they got this HUGE roaring music and cinematic.

If you want to see it:

http://www.youtube.com/watch?v=YuRafRbdG20

Thanks MMOChampion!
Bravo, you guys fixed this fast, I only started the stuff in the area Weds PM and everything went OK for me, only bug was that when Hellscream jumps off the boat and has a couple lines of dialogue, he despawns right after beginning the speech, probably because of the phase change happening maybe 10-15 secs too quickly. Other than that, enjoyable so far, cinematic was great!
Enetring the second last phase the three peopel that we need to recruit one of them is always missing or 90% of the time is missing ... been happening for the last 3 days now

Join the Conversation

Return to Forum