WoWTCG loot redeem Captcha not displaying

Website Bug Report
Hi there,
I have a loot card which I tried to redeem on the website. When I hit a link on that website, it took me to a Blizzard loot redemption page. To redeem the card, I had to enter what was displayed on the "Captcha" display. However, that never displayed correctly. I was getting a 300x77 pixel strip on the top of the Captcha window. I cleared my browser cache, changed my browser display size, did a fresh install of Flash, Shockwave, and Java. But it still did the same thing. I wrote a ticket on the website, and was told to try a different browser. I have tried Firefox, Chrome, and IE and still get the exact same 300x77 pixel strip. They then told me to try writing here and see if the website tech guys could help me. I have screenshots of all three browsers trying to display the Captcha box.
Thank you for any help.
I'm having this exact same problem. Tried on all 3 of the same browsers. And not having this problem on any other Captchas aside from this one.
I have a similar issue with mine my security code picture loads half way then it does not load anymore. Did anyone find a solution for this yet?
Same problem and have tried all of the things that OP has tried.

Join the Conversation

Return to Forum