Random disconnect, cannot log back in

Technical Support
About an hour ago I was going about my business on my realm when I had a very random disconnect, I've been trying to log back in but it keeps asking me to choose my realm and realm type and whenever I do I just get auto disconnected again.

I've checked and double checked and my realm is working fine, I've never ran into an issue like this before. I'm wondering if it has anything to do with playing around with the character transfer function. I was planning on transferring my character to another server tonight and so I was going through the options and clicked to transfer not expecting for it to work, but to see what things needed to be done for it to happen. It said it wouldn't work because I had auctions up and so I just closed out the window for the time being. About 45 mins after that I got this random disconnect and have been unable to log back in.
It's not the character transfer, trust me.

I started having the same problem this afternoon. What's going on, Blizzard??
Having same problem. Went to log in, then was asked to select a server, I did, then hit ok, then disconnected.
There seemed to be a very fast update after I exited WoW and started the program fresh. Then I had to agree to all the terms of agreement again, choose North America from another window of options, etc - just like a fresh install.

Problem went away right after.

Or, it could be a random coincidence. Anyone else get a fast update?
That's probably it, I exited game and started fresh, installing update atm. Will check back tho let you know if it worked.
I "read" the maintenance agreement, selected the type of realm, and was then taken to the character creation screen (skipping the actual realm selection) as if I had no characters.
Backing out of that brought me to the character selection page. Whew!
Yep yep. It was a little bit of a pain but the problem is GONE. I suspect it was because of the pending update, restricting entry into any realm to keep worse problems from happening. I had left WoW running all night. I think that's really it.
Update installed. Game working properly for me.
Congrats! I'm kinda stoked that the debugging of the problem worked. It's the kinda thing I used to do for a living. :-)

Join the Conversation

Return to Forum