App thinks account is banned/suspended/locked

Mobile Bug Report
As of today the WoW Armory app won't allow me to access the mobile AH or guild chat as, I quote, "This World of Warcraft account is locked, banned, suspended, or under review. This feature cannot be used until any outstanding issues are resolved."

After seeing this message I immediately logged into my WoW account to see no such restriction to logging into the game itself and checked my email inbox and junk mail for anything about the account being under review with no avail.
Im also having this issue. Kind've alarmed me at first but after logging in to the game normally, I was a tad confused. Is this a known issue?
I am having this issue as well. Any insight into the problem would be appreciated. :)

I am unable to use the AH or Guild Chat features, and the amount of gold that each character has no longer shows up beneath their name and realm.
I am also having the same issue as well, scared the crap out of me, i thought i may've been hacked or something, but online works fine it's just the mobile armory.
Me too, perhaps due to the normal maintenance on tues? Makes me worry and I won't be able to check in game until I get home, and of course the customer service lines are not open until 1pm my time . Blue post would really make me feel better
Have this error too, nearly had a heart attack.
I saw the same thing, checked my account and the account status was "Pending" and the expiration was early this morning. I have the automatic rebill enabled so I'm guessing that something happened to that system overnight; the attached card is still valid.

Either that, or there was a CyberMonday field day with cards and the bank is behind checking on stuff?
/begs for a blue response
Ok well at least in my case I have an answer, perhaps it applies to you guys too. Call center says it is because my recurring payment is in that limbo phase between bieng billed and bieng payed, hence mobile app looks at it as the account is "expired" because the last payment ran out at 5am and new one has not posted yet. They also say that the game servers give a grace period for this that way your not locked of game. They just haven't got the mobile version to recognize this yet.. So in my case all is well, hope you guys are too.
Im having this issue too. I havent been home to check if I can log in game though, but hopefully like you guys have said it will still work
"This World of Warcraft account is locked, banned, suspended, or under review. This feature cannot be used antil any outstanding issues are resolved."

Um, no it's not. I was using the mobile armory just fine (renewing auctions) when I switched characters and suddenly got this warning. I tried switching characters, relogging, stopping and restarting the app to no avail. Perversely I can use the app on characters on an associated account but not this one. As you can see I'm logged in just fine here and I'm also able to access the AH from in game.

What gives?
Same issue here, I just logged off the game, went to lay in bed, but I felt the need to check the AH, and sure enough I got that message that my account is locked, banned, or something else

Weird thing though
I have exactly the same issue.

When i first saw this i immediately logged on to my E-Mail to find no messages from Blizzard about anything concerning my account. So, i attempted to log into my account in game which i had no issues with, checked the AH, looted mail, posted some auctions, nothing seemed to be amiss...

I just can't use my remote app at all anymore. :(

I don't know if any of these actions would be related to this error but here's some things i did out of the norm last night before my remote app "banned" me.

I did trade a battle pet in game for 5,000 gold.

I also noticed the remote AH doesn't show any battle pets i posted on the AH in game as active auctions. I discovered, IF one of these pets sold, it would cause the remote app to crash if i tried to view my completed auctions tab until i looted the completed battle pet auction in game.
Have the same issue.

Droid RAZR Maxx HD
Android 4.0.4
Oops. Which I saw this before posting my own. I am having this issue as well.

One of the above posters seems to have the right idea. My account is listed as "Pending" and my renewal date is today. There may just be a delay in processing from the credit cards for recurring accounts.

At least I know it's not just me, even if my bank character's mailbox is overfull and waiting to get reposted... heh. And I sure as !@#$ ain't doing it the old-fashioned way anymore! ;P
I am having this same issue. I was playing WoW on my two accounts earlier just fine and I went for a nap but couldn't sleep so I decided to log in to mobile armory. When I tried a toon from one account I could log in just fine but when I tried any other toon from the primary account I received this message. I only just added the second account on the weekend so I don't know if I would have had this problem before.

Furthermore the account management site isn't working for me (my browser can't find it for some reason) so I can't check if this is a pending payment problem on my end.

ETA: I finally got into my account and it turns out my account was pending as of 5am this morning. So I guess once our accounts are active again the problem goes away.
For what it's worth I have the mobile armory on an iOS device and an Android device (both are up to date) and I am having the problem on both devices.
I also am having the same issue. A blue response on what is happening on this would be nice.

Join the Conversation

Return to Forum