App thinks account is banned/suspended/locked

Mobile Bug Report
I also had the same problem today and still do. Had me nervous but I am still active ,obviously. Not sure why this is happening though.
This is being investigated, but the origin of the issue is not on the mobile server. Unfortunately I do not have a time estimate for when this will be resolved.
I'm getting same thing. Message is: This World of Warcraft account is locked, banned, suspended, or under review. This feature cannot be used antil any outstanding issues are resolved
i too am also getting this error message.
same problem also. would be nice if this was addressed publicly as a known issue, so we don't have to go searching for the answer.
jI've encountered the same error I have multiple accounts and the account I play daily is locked in the mobile armory yet the accounts I have for my wife and kid are both able to log in....sadly these are not the ones that have the auctions I want to monitor nor the gold to make the purchases
Getting the same error here. Way to go giving people heart attacks first thing in the morning.
Getting this as well.
Having the same issue with my iOS mobile app, was working yesterday just fine.
Installed mobile armory on my kindle fire just now and saw this error message. I tried it on my EVO, and it said the same thing. I panicked, for a second, then was confused when I was able to log into the game normally.

:(
I have the same error message. I logged on and had no problem playing, but the mobile armory still gives me the locked account script.

I found in breaking news where blizzard said:

"We are aware of an issue that is causing the WoW Remote app to display an incorrect error message to players whose account subscription status is Pending. If you receive an error message that states “This World of Warcraft account is locked, banned, suspended, or under review” when you log into the WoW Remote app, please wait until the pending transaction completes and retry the app."

I checked and my account is pending. Hopefully as soon as the transaction is approved, I will be able to log into the app again.
Same issue, and I am billed every month and am Type A with getting my bills paid. Sub has never lapsed.
Same problem here. My billing cycle is today and the payment status shows "Pending" also. if that helps.
I will add some more info to this.
I have not had a problem with the app until last night. It gave me the error that my account was suspended, locked or banned and so forth.

The steps I took were to uninstall the app and reinstall it. This did not work so i calle it a night.
This morning i try it again before i log onto the game and it allows me to access the auction house however the app will no longer remember ANY settings that are set including my login causing you to log in and everytime and change all of the settings again.

Hope this helps some more :)
12/20/2012 07:50 AMPosted by Roml
Same problem here. My billing cycle is today and the payment status shows "Pending" also. if that helps.


Having the same problem and my account is pending...Have we discovered the issue? DUN DUN DUUUUUN
I'm having this same issue. Thanks for your hard work fixing these sort of bugs, Blizz guys!
I am haveing same issue aswell, happened today.
Same here. Just started today.
i don't know if it had to do with it but my phone just had it's software update last night?
This is directly related to the PENDING payment status on WoW accounts. On the day that your account's subscription recurs, it enters this status. Battle.net was handling this in a weird way, but a hotfix will be out to address it shortly.

Join the Conversation

Return to Forum