Scenario: A Little Patience

Dungeons, Raids and Scenarios
This salts by balls, so i can't progress to the dailys until this is done, but of course i can't because its bugge
If you pull the last elite Mobs into the water and kill them, then slowly walk up until scargash until he jumps down, he will be targetable, just tested this more than once.
I found this Scenario to be slightly annoying at first but if you talk to the individuals with chat balloons above thier head's it will start the event. They then head off to area's where they start construction on traps with which to slaughter the horde. When you get to those construction sites there are various things you can interact with. If you click on them they will tell you what you need to make them work. You get the workers tool from a small chest near Varian. Water from the water elementals. Chunk's of meat from tigers, apes and crocs. Oil from the snakes on the ground. Rations from the stealthing horde. Wood from the wood piles in the area's. So on and so forth.

I actually really like the concept and execution of this scenario. I wish that there was a bit more in the explanation of how it functions so it wouldn't be as confusing. However my major gripe about this scenario is the timer for Varian's patience. I've done it a few times now, the first time we didn't beat the timer for constructing the defenses because we hadn't a clue what was going on. Once we worked it out we were able to construct the defenses before Varian's patience ran out. However the timer just stops and there doesn't seem to be anything that you get for doing that. No buff/achievement/notification that what you did has any actual impact on what's going on at all that I could see. It would be really nice if that could change. Otherwise the timer is pretty useless and just makes Varian seem like he's being a pest for no reason.

Instead of a trite, snobby is what she wants to on "dungeon finder" on "scenarios"...choose "specific scenarios" and you'll see "a little patience"...

Considering this scenario was in patch 5.1, a lot of folks might never have done these things before...
It wasn't too bad, considering when you click on something, you get a huge message on half your screen that tells you what to use it for.

It did glitch out though. The first group I did decided to finish up the Gnome trap first before starting the Night Elf trap. We finished the Gnome one with no problem, but by the time we got the Night Elf one, they Night Elves were all terrified and we couldn't do anything about it. I had noticed a big elite Mogu spirit that spawned around the same time as the Saurok that attacked the Gnomes, but we ignored it until we finished the Gnome area, and by that point, we couldn't find the spirit anyway. I think it had completely despawned so we couldn't finish it, and for some reason we couldn't requeue for it.

So in the second group, I headed to the Night Elf trap and did it by myself while the others did the Pandaren one. I finished first and went to help out...they were at 213/1000. They never even bothered to wake up the Pandaren and apparently didn't notice that nothing was budging. So I gathered the water and woke them up. It was annoying having to do around 80% of the scenario by myself because my other group members were too incompetent to read the YOUR PANDAREN ARE ASLEEP! WAKE THEM UP WITH WATER! message that blared across their screen. I don't even know what could be done to fix this, since the message could hardly be more obvious.

I think the scenario was interesting, I liked it.
11/28/2012 07:17 PMPosted by Flintte

Your camp is inactive you can not use that item [water]
Same issue here, untargettable boss.
What is so difficult on grasping the situation without hand holding? You are told where to find every material. Most are quite obvious, like the animals dropping meat or water spirits dropping water. Oil you gotta find the snakes and tree vines are sparkling all over. Sometimes you get an elite mob that will give you and the construction workers a nice little buff. All in all, you are told what to do. You just need...

A Little Patience
Woman in WoW: - Weak, needs to be saved/guided. Ex.: Tyrande, specially during the War of the Ancients- Strong, but pretty much always wrong. Ex.: Jaina wanting to blow up Org- Bat!@#$ insane. Ex.: Maiev

-Inexplicably no less physically strong than men.
From the 11-28-2012 hot fix:

It is no longer necessary to slay the Kor'kron Elite preceding Commander Scargash to engage him.

Hopefully this will resolve some of our concerns about the scenario.
wow i have so much fun doing this having no clue what to do can we havemore like this i sure love doing nothing all the time.
11/28/2012 07:35 PMPosted by Firestyle
Same issue here, untargettable boss.

skip the group of elites and fight scargash at the top of the ramp.
From the 11-28-2012 hot fix:

It is no longer necessary to slay the Kor'kron Elite preceding Commander Scargash to engage him.

Hopefully this will resolve some of our concerns about the scenario.

it wasn't necessary before either? i skipped the group my second time in tuesday night
This scenario is an example of lazy developers and lazy designers. What's wrong with you people, Blizz? Loose all your competent people when MoP released? Pittiful.
I loved the concept, but this was one of the most painful experiences I have had in MoP so far.

10 minutes in, I've gathered several items, ran back to camp and right click on stuff to give them to the camp over and over. One member complains that "this is hard with only two members helping with construction." I assume he means I'm the one doing something wrong, because I still have no idea what I'm supposed to be doing. I try right clicking on everything I can, there's nobody to talk to and nothing to interact with to "help with construction" or explain what I'm supposed to be doing. So I just keep killing things and turning items in, with no clue what effect the items have.

20 minutes into the scenario, we are still 0/2 of stage one, with half a progress bar full. One member finally gives up and leaves. (This is the second time I've tried the scenario by the way; the first time I tried it, the other two members left immediately and I ended up with a 30 minute debuff because I didn't want to solo the scenario). Another 20 minutes or so later, we've finally finished stage one. We stand around watching dwarves fire cannons for a couple minutes, with no indication what we are supposed to do next. At this point I just want to pull my eyes out, then finally I notice in the corner it says "Commander So-and-so killed: 0/1". Oh. That came out of nowhere, but ok. So we go and kill the commander, no problem.

Ugh. I love the idea of scenarios, and I especially loved the concept with this one, but this experience was so painful I don't think I want to bother queueing again. The sub-par random loot just isn't worth sludging through this half-assed content. Sorry Blizz. I still love you though.
11/27/2012 08:22 PMPosted by Shivar
Cleared it first go... it's not that hard to get your heads around it

You build up a couple of bases by collecting stuff and turning it in. Once that's done, you go kill the orc commander guy. It's not complicated.
Its by far the most annoying and most boring scenario.

Its also terribly implemented.
Blizzard clearly designed "A Little Patience" scenario as an intelligence test.

Great News! I completed the scenario my very first time just by reading the instructions. While my 2 party members ran around aimlessly the entire time asking what to do.

Join the Conversation

Return to Forum