[mod:shift] macro help

UI and Macro
I have [mod:shift] and [mod:ctrl] macros on most of my buttons to save space. They worked fine yesterday. Today, when I press shift, I can see the tooltip change, but the power doesn't activate. Is anyone else having this problem? Any idea what is going on? Maybe Blizz hotfixed something?

I tried poking around in my interface. My shift and control buttons are still unbound.

Any help would be appreciated.
If you can show us the actual macro, it'll be more likely that someone can help.
Things to check:

1. Is the CTRL+KEY and/or SHIFT+KEY combination bound to another function in the Keybindings menu?

2. Is CTRL or SHIFT set as your SELF or FOCUS cast key on the Interface Options > Combat section?
I figured it out, guys (sort of). My mouse (Razer Naga) has stopped recognizing the shift press. I can use my macros from the keyboard, but not from the mouse. It worked fine before, so there must be some sort of update needed since Blizz's update today.
Neither are keybound or set up for the self cast. I finally figured out it's my mouse, not the macros. I'm looking for how to fix that problem now. Thanks for your time!
Shift + numpad are reserved functions in windows and you can't bind things to this.
If you switched your mouse preset from regular 1-0 to numpad 1-0, that would explain it (switch is on the bottom of the mouse).
I have a mac laptop so I don't have a number pad. What apparently happened was that Blizz's update didn't jive with my drivers any more and I had to re-download them. It works fine now. Thanks for your help, though!

Join the Conversation

Return to Forum