Launcher stuck at Initializing

Mac Technical Support
What gives?

Internet is good and fast, nothing blocking the program etc... just stuck on Initializing.
A similar problem to me. It stays there for a bit then has a 'quest failed' sound with a pop up that says this.

"Failed to read a required file. Please close all other applications, temporarily deactivate your anti-virus software, and try again."

Did that, still does that, and selecting the WoW app itself just delays and doesn't come up so have to force quit that.
Ditto.

"Failed to download a required file. Please check your internet connection and try again."

Well... I tried checking and it's obvious my connection is okay as I am posting this message. I have the 1.0.0.1113 launcher and MBP-Retina (2.3GHz Core i7, 8GB). Initializing, but 0.0% complete.
Had same issue, started the game as normal, and the initializing screen hung; exited out, a pop-up "This program failed.. yadda yadda.. send to Blizzard", closed that (did send it), but then instead of launching "World of Warcraft" I launched "World of Warcraft Launcher" instead and that worked for me.
@Kysara

Yeah, I'm impatient. Especially, when I just played last night. I double-clicked on the following in the WoW folder:

World of Warcraft
World of Warcraft Launcher
World of Warcraft-64

None worked. Oh well... I downloaded the WoW Setup program and launched that. It's not downloading something that is over 600 megabytes. Hopefully, whatever it is, it doesn't screw up the game. I would HATE to reinstall the whole thing again.
Small typo (but BIG difference):

It's NOW downloading something that is over 600 megabytes...

Join the Conversation

Return to Forum