Patch Not Downloading 5.1 Help.

Mac Technical Support
Ah yes I see what you mean.

Just get back to me. I am refreshing the page every 10 minutes or so. ;)

Appreciating the help so far.
So try this to see if it resolves your issue. You may want to make a backup copy of your WTF and Interface folders from WoW to another location just in case this reinstalls your whole game.

    1. Download the latest Mac Installer from Battle.net Games Management section. (Don't run this yet)
    2. Delete the Battle.net folder located in /Users/Shared.
    3. Run the World of Warcraft Setup file.
    4. Point the installer to the current folder path of World of Warcraft.
    5. Run the installer.


Theoretically it should just detect the missing files and replace them. Though I've seen this only happen for a missing launcher. A missing WoW.app file may cause it redownload the whole game, but I've only seen this happen every so often.
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
Requires me to re-download the whole game. I am just going to do that. I get 7MB/sec download so it shouldn't be too bad.

Saved my WTF and Interface folder and I will drag in after the download, hopefully I don't lose my Keybindings or AddOns or I'll be disappointed.
Sorry about that. Well I'll send that feedback up about the missing WoW.app file. Do you know if this was moved or deleted?

At least we saved your addons and configs.
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
To be honest I do not remember ever seeing anything other than the "WoW Launcher" and the "World of Warcraft-64.app". After I started playing WoW and it just booted up from the WoW-64.app I believe I deleted the Launcher because I saw no use in it. The regular non-64 .app I never remember seeing.
Thanks.

Even if you don't use the file, it is recommended to leave all app files where they are in the folder. If you want to use a desktop shortcut, create an Alias, or drag the icon to your dock.

Let me know if the issue persists after the reinstall.
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
Will do.

Thanks for your help.
Re-installing did the trick! Case closed.
Right, but there should be 3 World of Warcraft files.
Here is what my folder looks like: http://i47.tinypic.com/1pzequ.png
Notice the 3 WoW files I have. They all need to be present to work properly.

Ok... I checked and I, as well, have all those files intact. I am still unable to even begin the installation of the patch. Suggestions?

I do not wish to have to reinstall the entire game. Halo 4 bekons so I'll check in here later and to see if this thread has any other info or if my individual ticket has been looked at.
Same Issue here. Opened up the launcher / Wow app and get internal error occurred. There is something awful going on with 5.1 for mac users :(
I'm a PC user and finding the same issue, not blizz just hating on mac's
I'm having a similar problem with my 64 bit mac running 10.8.2 OSX.

The Launcher stays on 0% for a while then pops up a window "Failed to download a required file. Please check your internet connection and try again".

My cable internet connection is working well with all other apps. And quickly.

All the required files mentioned in the blue post above are present in the WoW folder.

I have been offline for a week while on holidays and was hoping to get back into it today (sad face).
We'll need to find out *which* file it's having issues downloading.

You should find something to do with it in :

Mac HD -> Users -> Shared -> Agent -> Agent.HIGHESTNUMBER -> Logs

Possible in a file starting with AgentErrors or one with "Errors" in the title.

Join the Conversation

Return to Forum