You have no items / creating auction error

Mobile Bug Report
Having the same issue as everyone else. I keep getting the "You have no items in this category" and "Item not found" messages. I do not have any of new Dominance stuff. I hope the issue gets fixed soon-before I start having Armory AH withdrawals!
Same problems here concerning Mobile AH.
I can not List or Relist from this toon. Other toons seem fine.
I do have dominance point currency and Brawlers access.
Same issue on my main toon, alts are working fine but is a pain having to mail things over to get things posted. Please fix, thanks.
I'm having the same issue, oddly things that were in the mailbox were showing up but trying to relist them would collect the current ah price then say the item did not exist, so I went back and then back to the item can tapped relist then confirm as fast as I could, which posted the item.. But still unable to create new auctions from what is in my bags/mailbox/bank. I do have the brawlers guild and have the dominance drops, so who knows. ( I can use other toons( this one just has the issue)
I had this bug for 4 days. It went away after I did a hand full of things. I do not know if any of them had anything to do with the bug but worth trying.

1. Logged out in the inn at the new quest zone.
2. Moved all Dominance items to bank even the things you pick up off npc ( I do not know the name of them off hand) to the bank. Then logged out then I moved them back to my bags.
3. Give it time to fix it self :).

I do not know if any of the above did it but that is all I can think of that I did differently for past days.

Hope this helps someone. It made me crazy.
Currently having the same problem as well "you have no items in this category" but only on my warrior please fix blizzard!
I just replicated the issue with the [Overidden Excavation Bot] item that I picked up from a box next to the Skyfire portal that appears at Lion's landing. I couldn't access my create auction house screen from the mobile armory with that in my bag. As soon as I dropped the item in the game and went back to mobile AH it started working again.

The same goes for the Skyfire Portal Regents. If I have that in my bag I can't access the Create Auction screen in mobile armory if I drop the item I can get to it just fine. The actual Domination Point Comissions do not cause a problem I can have those in my bag and access the create auction screen on mobile armory it is just the items you purchase or pick up from one of the purchases that seemt o cause a problem for me.
I have this problem as well. I try to use the mobile armory on my iPad 2. For me the item that seems to be creating the problem is the imperial silkworm. I have a few max tailors and have got the silkworm on a few of them. On any character that has the imperial silkworm in their bags, when I go to "create auction" I get the previously mentioned "no items in this category" error. In the live game, I put an imperial silkworm up for auction as well as a few other items. When I go to that character's "my auctions" in mobile, I can see all items up for auction except the silkworm.
Same issue. Domination Point Commissions in bag but no purchases. Second day. only affects create auction and when you try to re-list.
Well for me its the new Potion of Lucks-the ones that now take 1 Golden lotus to make vs the previous 3. Everytime I have it in my bag I cannot create auctions via the mobile armory. Just to be sure I transferred it to an Alt and now the ALT can't create auctions but my main can.
Well for me its the new Potion of Lucks-the ones that now take 1 Golden lotus to make vs the previous 3. Everytime I have it in my bag I cannot create auctions via the mobile armory. Just to be sure I transferred it to an Alt and now the ALT can't create auctions but my main can.


This was my issue as well. When I moved the Potion of Luck out of my bag I was able to see items and create auctions again on this character.
Same problem here.

iOS6 i5
same problem with same issue, after getting Dominance, hope blizz can fix it asap~
I'm having this same issue. I'm still trying to pinpoint which item is causing my character to be locked out of creating auctions, but I have it narrowed down to being one of my glyphs. I sent everything (enchants & glyphs) from my "problem" toon to another. That allowed me to create auctions again but it just bugged out my other toon. Slowly in the process of figuring out which glyph (or glyphs) is causing my problems.
The fix of deleting the new faction items worked like a charm. For the record I had 2 portal shards and a couple hundred tokens. I deleted the shards ONLY and kept the tokens. Closed the armory app completely, waited 5 mins, relogged and all has been perfect.
Thanks Wilebosk - good to know you are looking into the issue and that I'm not alone!

In case it helps the toon the AH wont work on has been in the dominance area and bought items, it is the only toon (azaliaa, warlock) that has and the only one not working.
Having the same issue here, I have some of the brawler potions in my bag at the moment, I am going to log in and delete them and see if that works.

Edit:

It seems mobile armory doesn't agree with the new consumables, because that is exactly what is tying it up. If you have any of the items purchased from the new faction or any of the consumables from the brawlers guild, mobile armory basically gives you the finger.

The fix is to sell or consume the items before you login to your mobile armory. Hope that helps.
Still not working, what is Blizzard doing to fix the issue?
I bought the valor ring and I think that is causing an issue now. I was able to create AH entries up until I bought that ring.

Basically it seems like any new items introduced in 5.1 are causing issues when trying to create an AH with mobile armory.
Same issue, create auctions function is failing.
I am able to relist items.
I have an Imperial Silkworm in my bags. Will try moving that off later.

Using Samsung GS3.

Join the Conversation

Return to Forum