Item upgrade option is bugged?

Customer Support
Ok, so to keep things short, I was very excited about the item upgrade feature. I was at 1450 honor, and did not have time to run one more and get that 50 honor to upgrade my shoulders, which at the time were 0/1 to upgrade requiring 1500 honor. I went to bed, with anticipation that today I was going to get the 50 for the shoulders, then work on the next 1500 for my trinks.

Now however, the shoulders say 0/2 to upgrade and they require 750 VALOR to upgrade them. I am mainly curious if anyone else is having this issue? If so, were you able to fix it? I have opened a ticket, but the wait time is 2 days, so I would love to hear from people before then to get a possible answer.

This is for the Dreadful Gladiator's Plate Shoulders? Checking myself it looks like the Voidbinder is asking for 1500 Honor, and only has a single upgrade available.

Valor should be the currency for PvE gear with an iLevel of 470+.
for all of my honor and justice gear it requires valor or conquest to upgrade, i was just playing all my items are still 0/2 to upgrade them, requiring valor or conquest, when it should be 0/1 upgrade, and require honor or justice

I understand the higher end gear requires valor and conquest, but my honor and justice gear is also requiring valor and conquest to upgrade.

Thanks for the response.
You might want to try disabling any addons you currently have to see if that changes anything. Though you might want to try resetting your User Interface.

If neither of those steps work please let me know and we'll see what else we can try.
So glad I found this thread. I am having the same exact issue as the OP. I actually accidently ended up spending and losing 750 valor (would love to get this back considering this is a bug)upgrading my dreadful gladiator's necklace.

So far I have tried disabling all of my mods (I use 10) and also deleting my WTF folder. Both actions unfortunately have done nothing to solve this issue.

Any other ideas? I took your advice and followed the reset UI instructions and I'm still getting this issue. I'm assuming it is server side since everything was reset to default. I have no idea why it is only affecting some of us.
Try the full UI reset, not just deleting the WTF folder.

Short of that, if this really is a bug, there's still the chance that it cannot be corrected by GMs. They can't fix bugs and while unfortunate, sometimes players do indeed end up having to pay a small price for it.
I deleted the cache, interface, and WTF folders. Is there anything else I am missing?

I don't see how this isn't a bug. It is not like I can control or govern what the item upgrade vendor is asking for in order to upgrade my item. :P

Asking for valor to upgrade pvp item or blue pve items is definitly not working as intended.

My theory is, if they can restore items, they can most certainly restore points! Its all code.
I realize that in certain situations, like someone "accidently" upgrading their item, they might choose to not restore those points, but I believe my situation is obviously different.
11/29/2012 07:24 PMPosted by Pîcky
I don't see how this isn't a bug.

I didn't say it isn't. I said to make sure that you do the full UI reset. You implied in your post that you hadn't.

If something is not working as intended then you need to post it as a bug in the Bug Report forums if you haven't done so already.

GMs cannot fix bugs and cannot typically refund due to a bug.

11/29/2012 07:24 PMPosted by Pîcky
My theory is, if they can restore items, they can most certainly restore points!

And it's a great "Theory", but it's not policy and nor are GMs the programmers who can fix bugs.
I already posted this in the bug forum. I am replying to this thread simply because a BLUE has taken an interest in it. I figured that might be a good idea and in the past when I have had item related issues, GMs have always been there to help out.
I have posted this in the bug forum, done a complete reset, and still no change, hope they fix this soon, glad to see, though unfortunate, that I am not the only person having the same issue.
Picky, I can confirm that you lost Valor points, instead of Honor when you upgraded the Dreadful Gladiator's Signet of Accuracy. I can't reproduce it though, as it keeps taking Honor when I try.

Which Voidbinder are you using?

Demonmonger, the same question goes for you.
Also, I tried uninstalling all addon's, and this also did not affect a thing.

One last thing, this is also a bug for sure, not related to addons, or anything UI.

It is a bug because a permanent change was made to an item, and the only way that this can happen is through the game code, which can only be done by programmers.

Hope this is fixed soon.

I am using the one that is in the Shrine of the Seven Stars.

However, I fail to see the relevance of which vendor I am using, as the issue is a permanent change that has been made to an item through code.
11/29/2012 08:38 PMPosted by Demonmonger
However, I fail to see the relevance of which vendor I am using, as the issue is a permanent change that has been made to an item through code.

The relevance would be, Demonmonger, if I am testing the one in Orgrimmar and not experiencing the issue, and the issue only exists with the one in the Shrine of the Seven Stars, that helps our QA department narrow down the cause.
A few extra pieces of information discovered.

The issue does exist in the voidbinder that is in Stormwind as well.

Also, I was debating buying the honor trinket that gives Crit. I owned the honor trink that gives Mastery, which was at 0/2 to upgrade for 750 valor because of the issues I am facing. The new trinket that I bought is 0/1 to upgrade, and does ask for honor when I do it.

Because of this, and overlooking that there was a hotfix on the 28th of November, ironically the same day I experienced issues, I am 100% confident this was a bug that was caused from this hotfix. Not entirely sure what it was, but as of Tuesday, Patch day, I was 100% fine with my equipment, and then Wednesday night when I got on my equipment was bugged.

I just logged in again, and the item does still correctly state that it requires 1500 honor and is 0/1 to upgrade, where as all other equipment states 0/2 yet.

Hope this information helps.

Vrakthris I used the vendor in Stormwind. And it was the dreadful choker, not the signet.

and many thanks for actually looking into this issue unlike the GM that already responded to my ticket with a very generic response (go post it in the bug forum).
Yes, I too would like to express my thanks Vrakthris, would be nice if all GM's did their jobs with dedication like you are doing for us.

Much appreciation,
11/29/2012 09:07 PMPosted by Pîcky
and many thanks for actually looking into this issue unlike the GM that already responded to my ticket with a very generic response (go post it in the bug forum).

That is the best advice that they can give, Picky, or to submit a bug report through the user interface. I have a little more leeway where I can test some reported issues as I am not a Game Master, but in the end this really needs to be addressed by QA and our Development teams.

As for any refund or reimbursement of the mistakenly spent currency, until the issue is investigated and verified we generally won't have a policy in place for such a request.

I've forwarded my findings for further testing, thank you for answering my questions. Hopefully QA will figure out what is causing it and we get it resolved.
I can't upgrade my Dreadful or Malevolent gear with honor or conquest. All my pvp can only be upgraded with Valor on my Death Knight. When I log onto other lvl 90 characters, their pvp gear CAN be upgraded with Honor/Valor.

It's really annoying because I'm honor caped and can't spend it to upgrade any of my Dreadful gear.
I understand Vrakthris but you did verify that I spent "valor" to upgrade a blue pvp item which is obviously a bug. I honestly just want this to be resolved asap since I am sitting at an honor cap with nothing to spend it on (was hoping to upgrade a couple of pieces).

Join the Conversation

Return to Forum