Item Restoration Issue

Website Bug Report
I posted this over on the general forums and on the bug report forums before being directed here so...

So due to my own stupidity with bad keybindings and a dumb macro I managed to accidentally disenchant my Dominator's Arcane Badge. Basically I temporarily keybound disenchant for ease of use while mass disenchanting things, forgot I did it and then later on when doing a pull hit my disenchant macro followed shortly after by a macro that had /use Dominator's Arcane Badge in it while having my badge in my inventory instead of equiped because I was using golden fleece earlyer... At least I assume thats how I did it because honestly all I really saw was suddenly I had a new shard and when I checked my inventory my shiny new trinket was dead :(

Anyways I tried to follow proper item restoration methods and the trinket didn't show up in my list... so I opened a ticket. While waiting over 2 days on my ticket I periodically checked my item restoration list and watched while various new things would show up on the list, but my Dominator's Arcane Badge would not, and then I received the following response to my ticket.

Greetings Lothane,

Thanks for contacting Blizzard Entertainment, Game Master Iagalridgett here to help with your issue regarding your mistakenly disenchanted item.

I can confirm that your Dominator's Arcane Badge is located in your deleted inventory at the moment. It's possible that you may have just checked to item restoration page too soon so it to have appeared yet. I personally will not be able to restore this for you, but don't worry, you have the power to restore this item yourself! :) Just make sure you still have the mats!

I've checked my list again since receiving this response to my ticket, including trying to filter it through the various methods available, and the item still does not appear to be on my list...

So I guess my question is what to do now? I suppose I could just grind more JP to replace it, but I could use that JP to upgrade a couple heroic items I still have... anyways help is appreciated.

Also please note I have already tried using two different browsers and clearing my cookies/cache, due to the fact that I can see things I DEed yesterday but not the trinket I DEed two days ago I can only assume the problem isn't on my end.
I think there might be an issue with upgraded items and the restoration page. The restoration page doesn't seem to list any items that have been upgraded.

Just noticed this when i went to retrieve a trinket that I realised was better than the one I sold it for ;)

Join the Conversation

Return to Forum