Tidy Plates and 5.1

UI and Macro
I am a avid user of Tidy Plates. With the most recent update to both WoW and the addon itself, they no longer work. At all. I've tried re-installing the addon, installing older versions of the addon and loading out of date addons, everything. It shows up in the interface menu, but no matter what I change the settings to it's still just the really bad Blizzard plates.

Is anyone else having this problem? What did you do to fix it? Really important, I dislike playing without tidy plates and am BEYOND frustrated that this is happening and I am unable to find any information on it at all.
its not working for me either.

but really? its a patch day. Some addon problems are to be expected.

Give it a day or three and the addon authors should have things updated/fixed. They have lives too you know.
I, along with several other users of this addon, are experiencing the same issue. I suspect we are going to have to wait for the tidyplates creators to fix it.
I have the same issue, tried the "5.1" one, reverted, no luck. HHTD is not working either.
Anyone having this issue using elvui? disabling elvui gets tidy plates working for me again, tried updating both elvui and tidy plates but I just can't have them both atm.
I got Tidyplates to work by downloading the most recent version from Curse and resetting it to the default.
Already tried that. Of course, I am using elv, so that may explain my difficulties.
Same here I only see the default blizzard frames. Using the last version of TidyPlates and Duffed v6 a suite that uses Tukui.
Hmmm, I will try the addon hunt then and see if there is another conflicting.

Quite a few.. I checked the box for LUA errors (Esc-interface-game-help-Show LUA errors) and then read which ones are giving errors and turned them off.
For me it is Mik's Scrolling Combat Text, Arkinventory and Zygor were the issues.

Tidy is working again though.

Edit - I also had to turn off Prat as well.

Also, I am running the 6.7.10 version updated Yesterday as well.
I tried it on a new level 1 character with no other addons turned on and it still didn't work so I don't think it's a confliction problem.

I can't get any of the other nameplate addons like aloft, or docnameplates to work either.
I disabled Prat and Tidy Plates started working again
Just an update, I had success in getting tidy plates to work after I disabled Miks Scrolling Battle Text.

Not sure how many addons are conflicting with tidy plates, but I thought I'd throw in my experience and what worked for me. Until an update comes for MSBT I'll just have to choose between it and TP.
I was having an issue with Bagnon. Disabled Bagnon and Tidy Plates works again. :D
Dear Blizzard,

After having used a nameplate addon for so long, now that it's broken, and I'm FORCED to look at the default nameplates, I can't IMAGINE how anyone does it! These are the WORST looking, over-sized/bulky looking things ever. All I can see is nameplates! Jesus, if ever there was a UI function that needed fixing THIS is it!
11/27/2012 02:01 PMPosted by Psyhard
I disabled Prat and Tidy Plates started working again


I've got Prat and Tidyplates together as well. However, you don't have to disable the entire addon, only the ChannelSticky component under Module Control.
Still struggling.
I was able to get the latest tidy plates working after updating to the latest mik's that was released today. Thanks for the help guys!
Dear Blizzard,

After having used a nameplate addon for so long, now that it's broken, and I'm FORCED to look at the default nameplates, I can't IMAGINE how anyone does it! These are the WORST looking, over-sized/bulky looking things ever. All I can see is nameplates! Jesus, if ever there was a UI function that needed fixing THIS is it!


Agree completely. They are ridiculously bulky & ugly - and it's a bit difficult (as someone who is incredibly used to the streamline goodness that is threatplates) to even see who I'm targeting as all I see is GIGANTIC nameplate with the standard blizzard plates.

Also of note, some people are saying that threatplates is currently working with the updated version of MSBT - getting ready to try it myself as I have both disabled and I miss them :(
Updated MSBT and turned off Prat, nothing.
11/27/2012 04:30 PMPosted by Xerties
Updated MSBT and turned off Prat, nothing.


Yeah, I updated MSBT as some people are saying it was working with the update it's still not working. What's weird is on another toon I can log in with every addon active EXCEPT MSBT and my threatplates will work, but on this toon that isn't working.

Join the Conversation

Return to Forum