Patching Issue 5.1.0

Mac Technical Support

I have recently tried to install patch 5.1.0 and it says it is installed however every time i log into wow it says "please install the patch and restart world of warcraft". Yet when i click the restart it says the game is up to date. I first thought it may be due to my mac however i have collaborated with a few PC friends and they are experiencing the same problem. I have scanned the threads and tried various solutions including deleting Battle.Net file, Reconfiguring exe files etc etc. Wondered if this was indeed a universal problem? and if so has anyone figured out how to fix it? or if blizzard will be doing so anytime soon?

Thanks again
Hi Smoogiee!

You see errors like this when one is using a client not from the region that one is patching.

Taking a shot in the dark, you may be using an EU client which inadvertently patched, is intending to patch or is failing to patch with our US servers and then getting confused.

I would suggest uninstalling your client, and downloading the English (US) version from your Download Games page. ;)
Can you copy/paste the contents of your connection.log file ?

It's in the Logs folder of your wow folder.

Join the Conversation

Return to Forum