"The Mission" Alliance Quest Bugged

Bug Report
I just faction transferred my level 90 from horde to alliance, so I need to redo the first few lvl 85 Pandaria quests to reopen the portals and such through phasing. When zoning into Pandaria for the first time after the cinematic plays, I fall from the sky to my death - the Skyfire is not there. When I resurrect and take the portal back to the ship, I die again, meaning I'm unable to start the entire Jade Forest quest line. It's simply not there. Meanwhile, a different version of the Skyfire is appearing in the new area if Krasarang Wilds. I'm not sure if that's related or not. Pease fix.
This is still bugged. I am not able to start The Jade Forest quest line because the Skyfire ship is not even in the zone. I've tried joining another person's group who is on the ship to enter their phase and the ship is still not there for me.
The Skyfire ship is STILL absent from The Jade Forest, completely for me since I am a level 90 who has unlocked The Landfall quest lines in Krasarang. This means that I cannot complete The Jade Forest storyline quests at all, since they start on the Skyfire *IN* Jade Forest.
Hi Nuggles, I also have this issue after a transfer from H to A and have logged a ticket but have had no reply yet. Fingers crossed this get resolved soon.
I have the same thing happened to me too, tried a lot of stuff to see if it would help but it still bugged out. Hope Blizz will help us soon.
I am experiencing the same problem, I am glad not to be alone on this one. I Just switched to Alliance on my lvl 90 and I had to start the quests in order to get the portals open etc. and blah blah blah......falling...dying....rinse lather repeat. Abandon, get, die....I have tried a million times. It is very irritating, I just want to get settled in with the Alliance! BLIZZARD FIX PLZZZ D:
Same issue. Have a ticket in atm. First response was to delete WTF, Cache and Interface folders. Didn't work.
Wtb blue, there is a few threads similar, some deleted, some on eu.
Same problem, the second the cutscene ends in Jade Forest I fall to my death. I've tried logging out and logging back in, abandoning and restarting, and praying. Still no response. The forums are always my last resort.

I'll toss my chips into this pot as well.
Same
Same problem... Died so many times *sigh*
Hope they'll fix it soon!
There's an npc named Taradormi in Lion's Landing that will fix this for you after you speak with them. They're where the dailies are in Lion's Landing
Once again blizzard shows us how important we are as customers. Not a single response or fix for this problem. Guess its time to hang up the WoW addiction. Thanks for nothing
Same stuff happened here, I was fortunate enough to get a GM to move me past this point so I could advance, but I came across the quest Love's Labor, which is totally bugged, and even the GM I talked to for that issue told me that there's no work-around for that quest at all. So like everyone else who faction changed from Horde to Alliance, I'm stuck, and left waiting. And don't even bother to faction change back to Horde, the first quest is also bugged. I forked over $30 thinking another faction change would solve the problem, but of course not. I was however able to call up and get a refund for my troubles... Still, I can't believe they haven't addressed this yet.
12/16/2012 09:24 PMPosted by Dreadnor
There's an npc named Taradormi in Lion's Landing that will fix this for you after you speak with them. They're where the dailies are in Lion's Landing


Everyone should thank Dreadnor. Seriously.

Coords are 89.6,31.8 in Krasarang Wilds

It worked for me anyway...same problem as the other posters...quest glitched-out as a result of faction change.

...except, as a druid engineer, I didn't need to die :D
I faction changed yesterday from Alliance to Horde and seem to be having the same issues i can not get to Pandaria at all.
I faction changed yesterday from Alliance to Horde and seem to be having the same issues i can not get to Pandaria at all.


ok, well this is a forum thread about horde -> alliance and not seeing the skyfire. a resolution was posted, by speaking to taradormi in lion's landing, krasarang.

your issue isn't this one, so perhaps there's a better thread for your problem?
its an air ship go up and you will find it it will show it on the mini map
i can't get gear because of this, and mean while my membership is wasting away.

nice one blizz yet again, only if you stopped wasting your time building motor bikes and fix the bugs.

Join the Conversation

Return to Forum