Recording video just makes blocks of colour

Mac Technical Support
I used to record videos regularly, but then I stopped playing for a few weeks. I didn't change and settings, there were no updates, but after logging in again, now I can't seem to record videos regardless of the settings I choose.

All I get is audio and a block of colours. I've turned off addons, restarted it, tried every possible setting. Nothing seems to work.

Has anyone come up against this?

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0

Hardware Overview:

Model Name: Mac Pro
Model Identifier: MacPro5,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 10 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: MP51.007F.B03
SMC Version (system): 1.39f11
SMC Version (processor tray): 1.39f11
Serial Number (system):
Serial Number (processor tray):
Hardware UUID: 46F13ABB-7952-54C6-B7A8-EF1964B4F208

ATI Radeon HD 5770:

Chipset Model: ATI Radeon HD 5770
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x68b8
Revision ID: 0x0000
ROM Revision: 113-C0160C-155
EFI Driver Version: 01.00.436
Apple Studio Display:
Display Type: LCD
Resolution: 1280 x 1024
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
This was a known issue in 5.0.5. This should be resolved in patch 5.1. Please try again after updating to patch 5.1 and the realms going live.
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help?
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
That's great news! Thanks!

If this happens again, please let us know. We were not able to reproduce after the 5.1 update.
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help?
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
i recently update to 5.1.0 and still has the color blocks issue, my specs are:

OS x 10.8.2

Nombre del modelo: MacBook Pro
Identificador del modelo: MacBookPro8,2
Nombre del procesador: Intel Core i7
Velocidad del procesador: 2,2 GHz
Cantidad de procesadores: 1
Cantidad total de núcleos: 4
Caché de nivel 2 (por núcleo): 256 KB
Caché de nivel 3: 6 MB
Memoria: 8 GB
Versión de la ROM de arranque: MBP81.0047.B27
Versión SMC (sistema): 1.69f3

AMD Radeon HD 6750M:

Modelo de chipset: AMD Radeon HD 6750M
Tipo: GPU
Bus: PCIe
Anchura de canal PCIe: x8
VRAM (total): 1024 MB
Fabricante: ATI (0x1002)
ID del dispositivo: 0x6741
ID de la revisión: 0x0000
Revisión de la ROM: 113-C0170L-573
Versión gMux: 1.9.23
Versión del driver EFI: 01.00.573
LCD color:
Tipo de pantalla: LCD
Resolución: 1680 x 1050
Profundidad de píxel: Color de 32 bits (ARGB8888)
Pantalla principal: Sí
Duplicado: Desactivado
En línea: Sí
Integrado: Sí

anything we can do? compressing options, resolution of vídeos, or just wait for another patch?

also, will be the movie recording supported for 64 bit client soon?

thanks :D
I have a same problem.



System Software Overview:

System Version: OS X 10.8.2 (12C2037)
Kernel Version: Darwin 12.2.1
Time since boot: 1:30


Hardware Overview:

Model Name: iMac
Model Identifier: iMac13,2
Processor Name: Intel Core i7
Processor Speed: 3.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 32 GB
Boot ROM Version: IM131.010A.B04
SMC Version (system): 2.11f14



Chipset Model: NVIDIA GeForce GTX 680MX
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 2048 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x11a3
Revision ID: 0x00a2
ROM Revision: 3707
Display Type: LCD
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: B5LMTF069718
Mirror: Off
Online: Yes
Rotation: Supported
Adapter Type: Apple Mini DisplayPort To VGA Adapter
Adapter Firmware Version: 1.03


Input Source ID: com.justsystems.inputmethod.atok25.Roman
Keyboard Layout: ANSI
Thanks. I'll bring this back up to the team and see what they can find out again.

Thank you for your reply.
I just fixed this problem by I think I should share the way.

1. download PTR client
2. backup normal client file
3. copy PTR "" to normal client

and now I can record movie with my 32bit normal client.
(I could record movie with my PTR 32bit client so I just tried this way.)

I'm not sure what the difference between old file and new file.
I can send you the file If you need it (or is it a routine method that delete the file...)

Sorry for my poor english.
best regards.

Would you mind uploading it to then giving us the link here.

Be sure to edit out your account email from it first.
Cool. I actually answered in another thread that users who experienced this should try the PTR to see if it is fixed.

Uploaded files.

- old file:
url removed by poko

- new file:
url removed by poko

Hope this help.

I'll edit this post in few days for removing links because I'm not sure if these URLs are one-time-use or not.

url fixed.

It looks like this problem is very complex >.>
01/14/2013 12:06 PMPosted by Pókotan
I'll edit this post in few days for removing links because I'm not sure if these URLs are one-time-use or not.


I meant to say to use as their Anonymous uploads get auto removed after 60 days.

Here are the differences in the Movie CVars :

SET movie "0"
SET MovieRecordingCompression "1835692129"
SET MovieRecordingQuality "0"
SET MovieRecordingWidth "960"


SET MovieRecordingGUI "0"
SET MovieRecordingQuality "4"
SET MovieRecordingWidth "1280"

There also appears to be a lot of CVars in your old that I've not seen used for a while. I'm not sure if defunct CVars could cause an issue there.

I'll need to boot up the wow client in console mode to see if I can confirm what the Cvars do.
I attempted the PTR switch and i was unsuccessful.
I have the same problem. I added the SET MovieRecording64BitsEnable "1" line to my wtf.config file to get it to work in 64 bit mode, and it records but the movie is all just big blocks of color. Sound appears to record fine.
I'm not sure... but in my case, Shadow Quality "High" and "Ultra" is not recordable.

1. Switch file and start client -> recordable

2. Change Graphics Custom from "Fair" to "Ultra" -> recordable

3. Restart client -> not recordable

4. Change Shadow Queality from "Ultra" to "Good" -> not recordable

5. Restart client -> recordable

well...just in my case >.>
Pókotan, if you were not Horde i would kiss you!

turning down the shadow details then restarting the client fixed my issue!

i did do the swap prior to this fix
Thanks for the feedback about this all. I'm, sending this up to our team for review.
Pókotan, your post fixed the issue on my PC as well.

Mid 2011 iMac running WoW in 64bit mode, with Ultra or High for Shadow Setting it records garbage blocks of color / graphics artifacts / whatever they're called.
Posting in this thread since it's on the front page at the moment.

I've had this problem since 5.0. Nothing has fixed it. Changing graphics settings doesn't fix it. Changing recording settings doesn't fix it. Reinstalling WoW doesn't fix it. Relaunching client doesn't fix it. Upgrading from 10.6 to 10.7 to 10.8 didn't fix it. It briefly worked on the 5.2 PTR, completely bug-free, but according to another thread, those changes were pulled, and it no longer works even on the current PTR.

Other threads I've posted in:

I've noticed that during compression, it just skips from 94% to 100%. Also, when it was working on the 5.2 PTR, I had access to 4 different codecs to use when compressing. That's not the case anymore. I only see h.264 (and I assume that doesn't work properly).

Edit: Wait a second. I just recorded a movie that worked properly. How did that happen? O.o Looking into this one....
Oh, wow. This... this is it.

What determines whether you get a garbage video recording is the shadow quality the client starts with, NOT the shadow quality when you record the movie. You can record with Shadow Quality set to High if you started the client with it set to something lower (tested with Low and Good), but starting the client with Shadow Quality set to High will corrupt the video even if you reduce the quality once WoW is running.

To reiterate:

1. SQ@High -> Launch WoW -> garbage capture.
2. SQ@High -> Launch WoW -> Change SQ to Low-Good -> garbage capture.
3. SQ@Low-Good -> Launch WoW -> correct capture.
4. SQ@L-G -> Launch WoW -> Change SQ to High -> correct capture.

Wish I'd found Pókotan's post when he posted it 2 months ago. -_-

Join the Conversation

Return to Forum