MOP Alchemy Trinket Not Dropping

Bug Report
When I first entered Pandaria, I was already 600 alchemy. I've quested all the way from 85 to halfway through 88 with the exception of running each dungeon one time and only one time. I've quested in Jade Forest, Valley of Four Winds, Kun-Lai Summit, and Towlong Steppes. The alchemy trinket has still not dropped. I recognize it's a "random" drop, but this is far beyond that, with the trinket supposed to be an extremely common drop.
I have several Alch toons and they all got their drop pretty fast. One even got it within the first few minutes of being in Jade Forest. However as I am getting my Monk leveled (currently 89) I have yet to see it drop as well. I have looted everything and ran the instances a few times each.

Honestly it's the only reason I was even questing/instancing otherwise I would have BG'd my way to 90.
Has anyone else seen this happen to them?
Yes my pally had 600 alch before he set foot into pandaria. No drop in 2 hours of questing... sounds like a bug.
Its also worth noting that I have two other alchemists both of which got the drop withing a few kills of entering pandaria. They were not at 600 when they began pandaria.
My shaman is in the same boat, this is my 6th guy that I am leveling from 85-90 (3 of the previous 5 have alchemy and they got the quest drop very quickly), my shaman just hit level 88 and still no drop .. my skill was at 525 when I started questing. Almost 2 zones of questing completed (herbalism is at 588 and alchemy is at 575).
Same issue. Dropped early for my other alchemist, hasn't dropped in two zones for this one.
I have killed at least 2k mobs and nothing. Put in a ticket and they said working as intended but I can't believe it. This item is very important since I'm trying to squeeze in to a raid spot tonight I'm not geared for yet.
I am currently in the same boat put in a ticket and was told that they do not see any issues and told me to go to wowhead to see where it drops from and go and farm it. was already doing this but gave them the benefit of the doubt went back and farmed some more tigers in jade forest after 2 hours 15 motes of harmony no alchemy trinket item... please help
Raised a ticket last night, got my response from a GM tonight.

"The issue you described is indeed a bug, the item does not appear to be dropping properly at this time"

goes on to say that they do not have an ETA on when the bug will be fixed :(

Interesting that 3 of us logged tickets and didn't get the same answer, I guess enough people have complained and they are now realizing that there is an issue.
Hopefully this will get fixed relatively soon. The alchemy trinket is a MAJOR part of the perks of the profession. It's not some minor thing like missing a pet, and it's not even a matter of convenience. It's not like a complaint that it's taking too long to get, it's just impossible to get this major perk.

I got feedback from two mods when I opened a ticket ingame. The first didn't seem to have any idea of what I was talking about (either that or misread my post to just not understand how the trinket worked), but the second did confirm it was a known issue. So hopefully that's the first step to fixing it.
I also received the answer

12/03/2012 09:02 PMPosted by Majikmon
"The issue you described is indeed a bug, the item does not appear to be dropping properly at this time"

Filled out a bug report, not entirely satisfied from the 40+ wait time for a gm response to get my question of "is this bugged or is this now intended" with a "sorry cant help here's copy pasta go complain elsewhere. "
If we all fill out a bug report it will push the fix sooner.
Wow, I'm so glad I just capped my Alch from skill level 1 today.

I am just so pleased. Thank you.
Well just got the quest drop tonight .. guess they did some sort of fix with the realm restarts today. Doing the first set of quests in Townlong Steppes and it dropped off an Osul Spitfire.
I was already leveled to 90 and picked up alch to power level it, the quest hasn't dropped in 4 days.
I've yet to receive the Stone on my Druid.

I've killed hundreds of Mobs in Jade Forest and VotFW and still nothing.

I haven't chosen what specialization I want for my Druid but I hope that wouldn't matter.

Edit: I got it on my Priest within like 5 minutes of being in Jade Forest.

Join the Conversation

Return to Forum