Flight Point Bug

Bug Report
I took a Flight point on my level 53 Warrior alt from Gromgol Base camp in Stranglethorn Vale to Dreadmaul Hold in the Blasted Lands and upon arriving at Dreadmaul Hold I was teleported to the flight point in Stonard.

My sister had a similar experience in Northrend taking a Flight point from Dalaran to the Nesingwary Base camp flight point where she was then teleported to the River's Heart Flight Point

I get this bug too. Soon as I land at Dreadmaul I am auto teleported to the Bogpaddle flight master.
I'm having it as well any time it appears I fly from shrine of seven stars on lightning's blade I basically get set back one flight point. Per the GM's request when I submitted a ticket, I disabled all addons and tried again and it happened. I was also told to reset my ui but I took this a step further and wasted my bandwidth and downloaded the client thinking it may be bugged and tried without putting my old folders in, no addons and it still happens. I just submitted another ticket on this as it is still happening. Please fix.
Known issue since it is a common problem among pretty much every player.
Any time I fly, in Azeroth or Pandaria, I have this happen.
But only on One alt. My main, Alhumbra.
I have the same addons, as the rest of my alts.
I have disabled my addons, I have reset/repaired my game files (WTF,etc), I have uninstalled and reinstalled.
I still have this issue ONLY on Alhumbra.
I pay for a FP, I arrive at the destination and Touch Down, I get a Loading Screen, I then find myself 1-3 FP's prior in the chain I flew on to get to where I was going.
What is the cause, to only happen on One of my 9 taken of 11 slots?
Why has this only happened since 5.1, but Pandaria isn't CRZ?
Will it 'spread' to my other alts as well now?
This is by all means the most irritating 'feature' I've encountered beyond the whole of the CRZ itself.

Join the Conversation

Return to Forum