[BUG] Some People Just Need Killing

Bug Report
Hi,

I was attempting to do the quest in Blasted Lands on this character, Some People Just Need Killing, and I would apply the disguise and go about sixty feet, and the disguise randomly dropped on me. I attempted several times corpse running, but inevitably gave up as I realized I had to fight through all the mobs back once more.

I don't remember that happening with any other characters when I did this quest.
Barump.
I just had this happen to me today, on my level 54 Shadow Priest. I was trying to just go along, very careful not to touch any hostile mobs. But the box randomly disappeared, and I was swarmed and killed. I looked up the quest on Wowhead and I was definitely going in the right direction, so I hope this quest will be fixed soon as I remember it being quite fun when it worked.
Same problem, I've found myself using the somewhat more conspicuous method of just killing everything in the path
I am having the same problem and ive been able to do this quest on my first time with my others characters
This quest has been bugged since 5.1. Thought maybe it was fixed and tried it today on my lock, 5 attempts, all fail. Just have to skip the quest or kill everything on the way to the quest mob. I believe it's a CRZ bug (same thing happening with dual mounts) since you're actually crossing zones in the cave system.

Working as intended though I'm sure.
Still bugged. Have lots of toons and did it with no problem. Tried it today on my lvl 55 Pandaren Monk, three times, and got slaughtered. Have to skip it.
Every time I tried this quest using while driving the box it would go to the actual time blasted lands and not the past blasted lands and I couldn't complete the quest since Hondo would disappear. I then tried by just running through the mobs of past blasted lands and it let me be able to kill Hondo and complete the quest. I'm thinking that the boxes are bugged. I hope that this helps you guys
I did Some People Just Need Killing Quest, got it phased to the Older Version twice, got into box and later it phased to the newer and all level 90's, can't complete quest. Please fix this so I can complete the quest.
I think it probably matters whether you are doing this quest as a high (90+) level, or the intended level (55ish).

I have done it on a large number of Horde alts over the last few months at the intended level with no issue, but I would not be surprised if this was a problem for high levels since the Nethergarde Mine actually sticks way out underneath Swamp of Sorrows - meaning in the course of questing you leave Blasted Lands and then re-enter without saying hello again to the time-phasing NPC.
I am a Level 100 doing this quest and twice I have talked to the time-phased NPC and it still happens to me.
I also phased out of low lvl blasted lands doing this quest. I found out that if you just take a left at the entrance of the cave you will see the dwarf guy and you can jump up to him.

Join the Conversation

Return to Forum