The White Pawn Glitched

Hi I was wondering if anyone has ever had a problem with The White Pawn, the quest you get after killing the orc warlock in the beginning quests when you get to the Jade Forest, You have to go and Collect 3 Clues from a dead soldier, a hanging flag, and a Fine Leather Journal in the front of the ship, I'm not able to click on the Journal at all, I've tried Reloading with /reload, abandoning the quest and repicking it up (5 times might I add), logging out, logging onto a different character then relogging, logging out of the game, and exiting the game and reopening WoW after i've exited, nothing has helped at all. Im still glitched and am unable to continue with the quesrs until i've finished. I think I might need GM/ Blue Poster assistance, but if any one has had this problem and fixed it please feel free to tell me how I just spent $200 transfering my character from horde on Darkspear to alliance on Zuluhed and reopening my subscription. I'm beginning to get frustrated at the fact that I can't even quest for 2 hours with out needing to go to the forms and starting a report to get something resolved.
It's more than likely still just that targetting bug that's been around since launch (which is everything clickable, nodes, quest items, mobs, etc). I just come back the next day after the server resets for that junk. Sometimes the logging out works but not always.
full bags maybe?
Yea full bags is the issue. Cleared up some space, problem resolved

Join the Conversation

Return to Forum