Stuck at "Updating Blizzard Launcher"

Technical Support
Prev 1 2 3 6 Next
Seem to be a few people lately with this bug. Agent.exe is the worst possible thing to ever enter any Blizzard game. Hopefully the Wow devs find a way to fix this terrible excuse for an updater. Much love.
I'm having the same problem. Windows 7. I've deleted the folders that support mentioned on the last page, but the bar still isn't moving.
Success! It worked.
I'm having the same problem... I tried all steps mentioned and nothing helped... I'm using windows 7 so maybe thats making a difference?
*edit*
I just checked my task manager and I have 28 Agent.exe*32 running... all are about 4000k
to everyone who has the agent.exe. try ending the process while updating blizzard launcher is up.
For those of you who tried the solution, but it didn't let you delete the Battle.net Folder:

Go to your Task Manager.
Go to Processes.
End every process with the name of Battle.net Update Agent.
not a bad idea but i have 28 of the argent.exe processors running so by the time i deleted a few they started running again and close process tree closed the launcher as well
I am having the same problem as Boffo and I have tried all the stuff on this page...
Followed All instructions on the first page and it worked perfectly! thanks alot!
Followed all instructions, no luck at all here.
Same issue here.
It was stuck at roughly two thirds of the way. I deleted my battle.net folder in AppData & deleted my cache & update folders in C:\Users\[User]\World of Warcraft

After doing that I noticed little to no change so I launched it with Windows Task Manager and manually killed 3 Agent.exe. Doing this made the update process repeat itself and about 5 minutes later it has put me on the Launcher properly. Now I have 352 MB to download but that is all.

I also had this issue a couple of weeks ago, with the advent of patch 5.1 (Landfall). Now with the patch that introduced the Cinder Kitten it seems the problem reoccured.

I hope this issue does not occur again in 5.2 but I have a feeling it will. Please sort this out as it is quite annoying.

Thanks.
Yeah im having same issue with my bar 3rd way done. pretty frustrating actually.
i dunno what to do FML
ok, so did everything here, and more, and still dont have anything. I am running windows 8 if that makes a difrence
same for me have tried everything been 2 days no progress fix your stuff blizzard!
same issue :( i really need to work on my priest but it gets to 2/3s just delated WTF/cache and still same thing tried the task manger and getting rid of agents still wont work :(
Same here, Ive tried everything.....im getting extremely tired of this... blizz fix this!!
Having the same issue on Windows 7. Keeping my fingers crossed for some kind of fix, because the one provided doesn't seem to be working, or else I'm missing some details.

This has been going on a few days now for me.
I've done everything in here and still get the problem of being 2/3 through the bar on the launcher.
ya same problem everyone saying i cant log in it gets stuck a little more then half way

Join the Conversation

Return to Forum