[help] @mouseover macro not working

UI and Macro
So I have a Holy Paladin alt I am leveling and I figured that it'd be a lot more simplified to heal people if I had to target less to use my spells. I tried to bind Word of Glory together so that it will heal @mouseover before it will heal a target, if one exists.

My problem is that if I mouseover a party frame and try to cast the spell, it doesn't want to cast that way. It won't even go ahead to cast normally on my target either.

#show Word of Glory
/cast [@mouseover,help] Word of Glory; Word of Glory


Not sure if I missed something painfully obvious.
So I have a Holy Paladin alt I am leveling and I figured that it'd be a lot more simplified to heal people if I had to target less to use my spells. I tried to bind Word of Glory together so that it will heal @mouseover before it will heal a target, if one exists.

My problem is that if I mouseover a party frame and try to cast the spell, it doesn't want to cast that way. It won't even go ahead to cast normally on my target either.

#show Word of Glory
/cast [@mouseover,help] Word of Glory; Word of Glory


Not sure if I missed something painfully obvious.


Don't bind mouseover macros to mouse buttons.

Unit frames consume mouse clicks. They're set up to respond to them for functions like targeting, context menus, etc. The click will be taken by the frame before it even reaches the keybind level.

Either
- Bind to a keyboard key
- use your mouse software to remap the mouse button to a keyboard key and bind to that key
- use the addon Clique
I don't see where the OP said anything about making the macro work as a mouse-click.

This should work:
#showtooltip
/cast [@mouseover,help][ ] Word of Glory


If that doesn't work then you need to check your Keybinds to see if whatever button you have the macro on is bound to something.
12/09/2012 04:54 AMPosted by Mitimem
I don't see where the OP said anything about making the macro work as a mouse-click.


Yes, he did. Right here:
12/08/2012 07:46 PMPosted by Shenanigans
My problem is that if I mouseover a party frame and try to cast the spell, it doesn't want to cast that way. It won't even go ahead to cast normally on my target either.


The only real cause for this behavior is if he's bound it to a mouse button. We both know the macro is correct if not a little verbose; there's no issue there. And even if he bound the spell to a keyboard bind instead of the macro, it would still at least cast on his target, whereas a mouse bind wouldn't work at all over the unit frame, spell or macro.

12/09/2012 04:54 AMPosted by Mitimem
If that doesn't work then you need to check your Keybinds to see if whatever button you have the macro on is bound to something.


That would only really be relevant to modifiers. The game won't let you bind two different actions to one key and it'd be a whole new level of stupid if someone thought they could trigger the macro through a bind without binding it.
Yeah Inien's correct, I do have it bound to a mouse button, and I can understand what you mean for why it won't work the way I have it.

So I just gotta go into the Keybindings and map a separate shortcut via keyboard use as the same action for the mouse button right?

Like BartenderBar blahblahblah ||| Mouse Button 4 / Whatever keyboard shortcut
No, that won't work either. You need clique if you want to bind to your mouse button without the unit frames eating clicks.
You're best off just not involving your mouse buttons at all when using @mouseover targeting.

However; in order to accomplish what you desire, you would have to go into your mouse drivers and remap the buttons to behave as though they are keyboard buttons instead. Unless you have a gaming mouse with extensive driver configuration options, this is probably not possible.

Join the Conversation

Return to Forum