Dominance Quest Phasing Shrine of Two Moons

Bug Report
I accepted (and completed) the Dominance Offensive quest, Echoes of Thunder (http://www.wowhead.com/quest=32351) 2 days ago, and I'm still stuck in the phase surrounded by Sha-Touched Grunts, quest NPCs, and an empty Shrine of Two Moons. I figured I'd wait it out until I get the next part of the questline (Get My Results!) which I completed today, and the Shrine is still bugged out. I tried zoning into other areas, logging out, cleaing cache, pet battling, etc.

I'll update if the restart tomorrow would do anything.
I did the next quest after the Echoes of Thunder and im still stuck at Shrine of Two moons, nobody is there but me and the guards, the event keeps repeating itself, there's the prince and the king and the Sha, then it disappears and when i come back it starts all over again
Same :(
Just to follow up to this, the server restart didn't help either.

I even tried phasing into other realms via Real ID, and it would just bring me back to my Sha-Touched Grunt-phase as soon as I left the group.
Having the same bug
Same problem here, kind of annoying because I only see like one person who is also probably bugged.
Having the same issue been a few days now.
I spoke to a GM a few days back about it and he try helping me out with it and according to what he found, only Devs can fix it, supposedly i completed both version of the quest for the Horde version is Echoes of Thunder, and the alliance one is Heart of the Alliance, my quest-log that he saw he sees both version been completed witch is impossible because i cant even talk to the horde npc to get it in the first place, anyways its a bug their working on it, supposedly they patch it through on the 11 of this month but im still phase out and its been 4 days now, might have to wait till server reset for it to works.
I too am having this issue... which is pretty iritating since the gear upgrading npc doesn't seem to be in this phase aaaaaaaaaaand its made it difficult to find a blingtron to do that daily :(

Edit: Turns out there's an item upgrade npc in org. Bug is still annoying though :(
same almost done with the whole quest line still the town is out of phase actually this is retarded
I'm having the same issue. I can't buy Golden Lotus from Danky. Wtf blizzard fix your !@#$. I don't want to be forced to buy flasks for raids!
I too am having this problem, unable to upgrade any of my gear, pretty soon my valor points will be going to waste, this REALLY sucks.
Im having this same problem as alliance but in the shrine of two moons. Now its not such a huge issue for me but i do enjoy flying over to the hordes city and ganking a few people while sitting on the hanging torch to avoid guards. Now i go there and the whole citys empty other than the sha grunts. When i did the quest for alliance in my own city the sha touched solders disappeared like the should.
Did they ever get a fix for this? I am phased to where I can't see anyone or anything besides the guards fighting out front. Over in Mistfall Village I can't pick up the quests and I cant see the guild member in my group either. When doing the pomfruit and the flower pickup quests I can't see the items too pick up.

Ooops thought I was logged in on my Hunter...druid not even in MOP yet...lol Character is my Hunter Wiibeasty.
I put a ticket in a week ago. The first GM logged on my character and apparently fixed it, i log on and was still phased. The subsequent GM responses said they couldnt do anything and they would pass it on to QA.

My Alliance toon can still not see any Horde at the Shrine of the Two Moon's. There was a hotfix on December 13th to stop this from occurring while on the quest 'Heart of the Alliance' however nothing has changed for me.

I think i am on to my second ingame bug report now.
Will there be any official response to this issue?
I am having the same issue on my hunter! I need to get my 3 Elder Charms of Good Fortune for the week! I will be very upset if this problem is not fixed before reset and I'm not able to get my coins on that character.
I'm having this exact problem. My GM ticket asked me to Reset mt UI which did nothing for me. I need to buy AC rep gear but cannot access the vendor. This needs to be fixed.

Join the Conversation

Return to Forum