Updating Blizzard Launcher STUCK!

Technical Support
Help, every time I try to launch World of Warcraft now for some reason I get a window that pops up Updating Blizzard Launcher and it gets stuck about 3/4 of the way through, my wow was working perfectly fine about 2 hours ago and i can't fix it!
My launcher is also stuck at the same part of the update. It says it's at 94.6% when it gets stuck. Under the 2 & 3 steps, it says "o bytes".
same here..ive tried different "fixes" and nadda
I'm at 90.1% and downloading the update a whooping 0 bytes.
I've tried the ending process of Agent.exe while the updating is stuck, it didn't work for me but might work for you guys, try it out.
I'm stuck at 0%. Even worse.
i have like 12 agent.exe processes going..is that right or wrong?
well i had a lot more than 12 becuase i kept closing and re opening my launcher, its normal.. just end them all.
Im have the same problem and read through all the forums and cant find a fix for this, i started the application, window pops up saying checking for updates, then says updating blizzard launcher, now im stuck around 60% in the specific window for about 30 min with no progress.
i let mine sit. it was stuck at 94.5% then i guess it was installing.. Then it went through
Im stuck also. Hope they fix it soon.

Join the Conversation

Return to Forum