Unable to fully download patch

Technical Support
So, when the larger patches drop, I usually let them download up to around 50%ish and go ahead and continue on to log into the game and allow the background downloader to finish it up.

However, 5.1 drops and I go about my usual and saw the DL hit 100% in-game, which for me is completed, but I have been having to download this patch every other time I bring up the Blizzard Launcher.

I just let the full download run before clicking the play button to go log in and got an error message:

"ERROR: The file "C:\Users\Public\Games\World of Warcraft\Updates\wow-0-16357-Win-final.MPQ" appears to be corrupt. You may need to download this file again."

Has anyone else experienced anything like this? Hoping to find a faster way than re-installing the game.

I currently have the same issue and cant figure out how to resolve it my game does the exact same thing i deleted the WTF, INTERFACE, and CACHE folders as the patch help guide says to do so and nothing. hopefully they fix it soon.
Ok, so it's a possible bug then?

Also, I tried to log in a minute ago and it was taken to realm selection window with all realms appearing down. I immediately grabbed my phone to look through armory. People were on in guild and realm status showed all realms up. Followed up on website, all realms up.

I've also emptied my folders since it seems to be #1 on the list to every issue. I hope they take care of the issue quickly.
You try deleting the corrupt file? That is what I had to do.
I was having the same issue. It took a couple of tries, but I went through the file and deleted the file it said was corrupt. After trying to reinstall the file a couple time, I was able to get it downloaded properly and on with my life.
Well, I'm trying the Repair Tool option on the launcher currently. Should this not work, I'll go about deleting and replacing.

I've tried doing a couple searches to find somewhere I can download the file by itself with no luck.
Any suggestions?
OK, that worked. I'm up and going!
Yup i get that same message my self and how do we fix it????
where do you find the file ?
Kaotic is correct, cheers to he :). the repair tool worked for me. thanks

Join the Conversation

Return to Forum