Blizzard Launcher's

Technical Support
Hey guys, I opened up WoW only to have it do a launcher update. At this point in time, it is stuck 2/3's of the way across and not making any progress. I have tried restarting my computer to fix this but the problem is persisting. Any idea of what I can do to fix this?
Are you on a Mac or a PC?

Either way, you'll probably want to head over to the corresponding tech support forum, they're usually really helpful and I know on the Mac forum at least there's a Blue who comments on almost every problem :)

Asking General probably won't get you the results you need :)
I am on a PC ;) thank you.
Update it is doing this for all of my blizzard games. Starcraft 2, Diablo 3, and WoW.
Kerex,

Lets try resetting the launcher game files.

  • Close any Blizzard programs (Agent, game launcher, and game installer).
  • Configure Windows to Show Hidden Files and Folders.
  • Navigate to the Battle.net folder:
  • Windows XP: C:\Documents and Settings\All Users\Application Data\
  • Windows Vista/7: C:\ProgramData\
  • Right click the Battle.net folder.
  • Click Delete.
  • Relaunch the game.
  • Thank you for the response, I will give this a try and update you after I complete the process.
    The BEST way to cover this is doin this:

    https://us.battle.net/support/en/article/enabling-windows-secondary-logon-service

    I have the SAME problem and this solves the problem :))
    UPDATE: Went through the process and it seemed to go through. The game is updating to patch 5.1.0a as we speak.

    This process got me curious however. How does deleting a specific folder help a program in mid download run the rest of the way through?
    Kerex,

    It doesn't. World of Warcraft is actually a collection of programs, not a single one. Deleting that folder removed the program that was doing the update. You then download a new copy of the program that wasn't stuck. It started over.
    Ah I see now. :) Thank you for the response. I should've known that seeing that I took two years of Game Design. Damn this head cold. ;)
    I had this same problem the otherday but after about 30 minutes it finally shot up an error about saying one of the mpq files in the wow/updates folder was corrupt and that I needed to re-download it.

    Of course the downloader automatically re-downloaded the file once I deleted the original and if I recall correctly the file name was
    wow-0-16357-Win-final.MPQ

    Though I cannot be sure that is the correct file as when all this happened their were 4 files in that folder and now their only appears to be the one.

    Join the Conversation

    Return to Forum