What's in the Box? quest bugged

Bug Report
Quest in the dominence offensive chain, bugged out, can talk to the required npc or assist with the experiement, anyone else having this issue?
Same thing happening to me. The npcs are hostile and attacking one another, and i cannot talk to them or attack them.
Same on Black Dragonflight. Except Aethas is the only one hostile, and cannot speak to him.
12/12/2012 11:39 AMPosted by Muster
Same on Black Dragonflight. Except Aethas is the only one hostile, and cannot speak to him.
Same bug, same realm, and oh hey look same guild!
Just wanted to say this bug is still present. Archmage Aethas Sunreaver is hostile, can't talk to him. Quest not able to be completed. Also his friendly Dalaran counterpart was of no help :\

edit: update just checked and it was fixed, archmage was friendly and I got it done
On Dragonmaw server and both Archmage Aethas Sunreaver and Grand Magister Rommath are hostile. Quest not able to be completed.
Same deal on Stormscale server. Archmage Aethas Sunreaver and Grand Magister Rommath are stuck in an eternal battle not allowing me to continue the quest.
Still glitched, ever since this morning too.
Worked for me now, they werent fighting eachother and I was able to complete it.

Cool speech by the blood elf leader. The fact that he was voice acted makes me think its gonna get heated up!
Bugged as well. Only Aethas is hostile. Cannot complete the 'Contain the Experiment' or 'Speak with Aethas' portions of the quest. Does this reset at Daily rollover (6am each day) or on Server reset (Tues)?
Bugged on my server as well, Bloodhoof. When I was there, another person from Llane had the same problem. Aethas was hostile and couldn't speak to him. Tried dropping the quest a few times and logged/relogged to no success.
Bugged for me as well, Aethas will not speak with me. Tried abandoning and getting the quest again, /reload and logging. I'll come back in a couple hours to see if it unbuggs magically for me.
its still bugged. :(
bugged on the malygos server as well
Bugged on Dragonmaw - I can't complete it.
It's been bugged all day on the Thrall server.
Bugged on Illidan, you can talk to everyone, and even kill the sha, however you cannot turn the quest in due to what im assuming is a phasing bug.

Edit: I've abandoned and retried this quest several times in many different ways, the way it worked for the zoning is you HAVE to talk to the arcanist outside the chamber first or else the quest will not zone in properly and you will not be able to turn it in.
Bugged on Khaz'goroth.

Can't talk to Rommath. Stated as a hostile. Any fixes?
Boulderfist still bugged

both are hostile and fighting

why has it been over a week with no fix or even a word from blizz

Join the Conversation

Return to Forum