Password Reset error!

Mac Technical Support
My brother was locked out of his account (probably from extended disuse). Now, when he goes to reset his password, as prompted by the "account compromised" email, he fills out all the fields but receives:

"An error has occured. Please fill out all required fields."

There's a field for his email address, his first and last names, and the generated security code input.

There are no other fields to fill in! Is the website broken or does he really have to spend all the time wading through the phone support system to fix this?

I was having the same problem about.....20 minutes ago...

What you have to do is use a different computer, make sure its not from a different I.P. address, and its as simple as that!

Hope this works for you
Torkår, you should have your brother begin here to recover his account:

If your brother clicked any links in the email he received, he should immediately follow the steps in the link I have provided and if he has not already done so, obtain either the Physical Authenticator from the Blizzard Store (any version will work), or the Mobile Authenticator for his iPhone or Android based smartphone. The iPhone Mobile Authenticator is available via the iOS App Store. The Android Mobile Authenticator is available via the Google Play store from your phone or tablet.

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
I bet you are using a mac. I am having the exact same problem every time I try to reset my password on my mac (I connect myself from different places often and I have to reset my password a lot, which is quite annoying btw). I tried using another mac and got the same error message but then I tried a PC and a smart phone and it worked fine on both. So it is definitely a bug with the password reset on Macs (the message error is "An error has occured. Please fill out all required fields." but the fields are all filled in).

I tried to use the link from above with the exact same problem. It would be nice if Blizzard could look into this problem since it only started happening to me about 2 weeks ago.
Allright so after searching for an answer online, I found this post which explains why mac users are running into this problem :

It seems that Chrome and Safari (webkit-based browsers) have not been playing well with Blizzard's websites lately and using another browser like Firefox fixes the problem.

Hope this helps people who are running into this problem.
My wife has encountered a version of this problem twice in the past three days. She tries to log in, gets the "you have to reset your password" message (we're traveling), clicks on the URL, fills in her information, is told she will be sent an email. She receives the email, clicks on its URL, and is back at the page which wants her information. It's an infinite loop.

The first time we eventually got a human being on web chat and he fixed it. Currently web chat is greyed out. She tried using Firefox instead of Safari and it did not solve the problem. I tried doing the password change for her from my computer and it did not solve the problem. So it looks as though the problem is somehow tied to her account and doesn't depend on which browser she uses.

Both of us use Macs. I haven't had the problem, she has. And a month or so earlier, she had a different problem--the software refused to accept the Capcha she put in during the password change problem. She tried about seventy times. That one also had to be fixed by a live human being.

When we get through to a human being, it seems to be a competent one--but somehow the problem never gets fixed for the future.
Grimmr - I had this same "infinite loop" problem all afternoon. None of the support articles helped and I couldn't submit a ticket. On my fourth attempt to reset, I noticed that the URL in the email sent by Blizzard directed me to their South East Asia site ( for resetting, whereas I had initiated the process on their US site. I pasted the link in a new tab, replaced "sea" with "us" and got the correct page, which requested for my new password.

I do not know why Blizzard would send a wrong link, really frustrating because I thought I had no other options other than to call.
This is something we're aware of and are investigating the causes. Thanks for the additional reports.
Btw still not working as of 3/7/13 and I am locked out of my account. I tried the other option of selecting "My account is locked" after clicking "Can't log in" and still just lops the page until it times out and says "An error has occured."
Still not working as 6-25-12

Join the Conversation

Return to Forum