"Interface\GlueXML..." Error Message

Technical Support
I've been experiencing issues with my latency for the past 2-3 weeks. I log on with around 113ms, which I'm comfortable with, but all of the sudden it will spike to 1300ms, and even as high as 3400ms. The spike generally occurs around an hour after log-in. Once it happens, it will either no longer let me connect at all, giving me an instant disconnection, or I will encounter high latency as soon as I log-in, with the disconnection shortly after. The "1-hour Spike" seems to reset the next day I start playing. Meaning that it will continue to disconnect me until the next day when I can finally get an hour of playing time in before my latency goes through the roof. My actual internet connection is at 54mbps, with 4G LTE, and I have no other problems with any other programs that use an internet connection.

But anyways... that's the beginning. Tonight, I starting dealing with the issue sooner than usual, after around 15 minutes of play-time, and then the spikes and disconnects come. After 2-3 weeks of this mess I've gotten into the habit of quickly trying log back in (Although it's very annoying considering I use an authenticator..) so I can get back to what I was doing

...until tonight.. when I received this strange error message, in HUGE RED SCARY LETTERS! that read "Interface\GlueXML\OptionsPanelTemplates.lua:258: attempt to call method 'GetValue'." I've already uninstalled all 3rd party addons and what not, but it did nothing. I would greatly appreciate it if I wasn't told to do this over while you (Blizzard) buys time to do a hotfix or whatever it is you do. I need this fixed. I hate paying for something that I'm not capable of playing due to crappy error messages.

Note: I finally was able to log back in after a few minutes with instant latency spiking, and when i received the disconnection message that I ordinarily get, and attempted to log back in, I received the error yet again. I suppose the error can't decide whether it wants to completely piss me off, or just agitate me...
Check your main wow folder for error logs and paste the most recent. Check the settings portion and edit out any personal user info.

Paste the entire long wall of text.
How would the Error Logs look? In my main WoW folder,
"C:\Program Files (x86)\World of Warcraft"
There isn't anything that says error, besides the two Applications; WowError & WowError-64.

Could you be specific in telling me where I could find this.

Thank you! (:
You likely don't have any then - it would an error.txt file right out in the open. Have you tried the standard game reset aside from uninstalling addons.

In the main wow folder delete the Cache folder, WTF folder and Interface folder - wow creates new ones when you log back in.

I would also download - update and run a Full scan with Malwarebytes.

http://www.malwarebytes.org/

The WTF contains settings - you will have to adjust your desktop and graphics when you get back ingame.
Should I run the repair tool as well? Or would that do anything at all?

Thank you, btw... for replying so quickly! (:
Sure run the repair tool as well. Let me know how things go - did you do that full malwarebytes scan?
im getting a very similar msg error and continue getting dced same symtons as he describeds here but i follow ur instructions and did not fix problem
I got the same error. It's really annoying cuz i pvp. After i used the repair tool on wow launcher and disabled all addons, it seems good now. I guess that some addon is outdated and causes the error.
My game keeps crashing, it started yesterday i killed myself in-game to reset the lag spike or the auction house, but it did not work, it would not let me resurrect or get resurrected by anyone. I've tried deleting all my cache, WTF folder, and interface/addon folder. The problem or in game issue still continued, so i removed world of Warcraft from my computer and re-installed it from my world of Warcraft account. Every time I opened my O window/ Friend list/ Battle tag list it kept crashing my game. Every time i typed in guild chat my world of Warcraft crashed, kept getting internal errors. The Auction house vendor window did not pop open left the Auction house and mounted and flew away from the auction house and then the auction window was available outside away from the npc.
I deleted my Cache, WTF folder and my interface folder. I also ran repair toon from the game menu. I hope it doesn't disconnect me from the game or crashes my game.
same problem in latin servers.. and blizzard closing forums... interface gluxml problem-...

ONE SOLUTION

To force server change... locate in WTF FOLDER.. then locate... config.wtf and edit last lines... and change the default server ur using... that way you can test other servers with less people..
everytime I log into wow takes me to the region selection I clck oceanic / normal when I click ok it disconnects me from server and I cannot get past this point, any ideas?? I have deleted the cach and WTF folder.

any assistance would be awesome.

Join the Conversation

Return to Forum