Updating Blizzard Launcher stuck.

Technical Support
My updating Blizzard Launcher is always stuck at around 70%. I don't know how to fix it and it's been like this for almost a week now. Any suggestions please?
Try turning on your secondary logon path.

- Go to start
- Control panel
- Administrative tools
- Services
- Scroll down and find the secondary logon service.
- Right click on it and go to properties
- In the area marked "Startup Type" change that to "automatic"

This is required now for WOW to install updates.

Some security programs shut this service off and it just needs to be started back up is all.
Unfortunately, I just tried that and it didn't work.
And I've tried the steps Blizz said to do... still nothing.
I to am having the same problem
same issues here and the fix didnt work for me either
Has anybody had any luck getting it to work? I just purchased a new computer and modem to run wow better and now have this issue.
I also have the same problem. it says updating launcher and the bar gets stuck at like 70%.
The only way i can play is if i go to the file location and open the game itself not the launcher.

....go to the shortcut in your desktop, right click it and then go to properties. open file location and then click the wow icon that dose not have launcher as the name. but i belive that it wont update the launcher in the way i just told you.
That's a nice simple solution. Create a shortcut to either wow.exe or wow-64.exe
i tried opening it and running from either wow-64 or wow-exe still nothing...-_- any other tips?
I am having the same problem....anyone able to fix?
Same problem here, started about on the 22nd of december, then I reinstalled WIN 7 64 bit, since that I also tried WIN 8 64 bit, but the issue always appears.

That's a nice simple solution. Create a shortcut to either wow.exe or wow-64.exe


NO! That won't work if a new patch will come, because we won't be able to update to e.g.: Patch 5.2.
I am having this issue as well. I've tried all of the fixes, deleted the indicated files, turned on secondary logon, restarted computer, deleted Agent.exe from processes...nothing has helped. I am getting quite frustrated and would really like to have this fixed ASAP.
I have Windows 8, and the above mentioned method worked great for me.

correction it only worked for a few days but then my mage got frozen trying to log in and now im back to "updating blizzard launcher".......
I am having the same problem too. I have tried for 4 days now to get in any help would be helpful.
Having the same problem on a Mac.

Only way to fix that I've found is to open Applications/World of Warcraft and delete Cache and WoW.tfil and Wow.mfil. Wait a minute and then try again.
this has been said before but, EVERYONE that is having this problem, go to the world of warcraft folder, scroll down till you find "wow" NOT the "World of Warcraft Launcher", double click on "wow" and it will open directly to the log in screen. This method will work with both mac, and pc users.

P.S. DO NOT drag the "wow" file out of the folder, your game will open that one time and the next time you try to open it again it will not open, leave it in the folder, or make a copy of that short cut then put the short cut on your desktop. Even when future updates come and you use the shortcut, it'll still update if you try to log in. Hope this helps
Thing is Dynomyte - come patch day which looks like Tuesday you will need the launcher working or there may be problems.
What should I do if I did drag out the folder? Is there anyway to fix it?
This is utter B.S. So many of us are having this problem, and never did before. I'm sick of Blizzard and Blizz azzkissers to tell us "O ur sistum ez ronyg! U need 2 feex et". NO. We didn't screw this up. As paying customers, we shouldn't have to move/edit/check for anything. The company screwed this up, THEY need to fix it. Not us. Everything was "working as intended" until this.
I have recently been experiencing this problem. I have a Mac. This did not start on mine until i was advised by blizz to delete a bunch of folders in my "WOW" folder and restart it. Now I get to about 70% it gets stuck on occasion. It is hit or miss. I use the apple menu to "Force Quit" the program. Then restart my Mac, It seems to boot right up after. If you have a PC try hitting cntrl, alt, del. and open the task manager then quit the application. Then reboot. It happens at least 3-4 times a week if i am able to get some playtime. I hope this works for you guys as it does for me. Hit or miss is not fair. I hope blizz finds out how to fix this. If someone tells you to delete some folders DO NOT, your updater does not work, don't risk not being able to play. Good luck to you all.

Join the Conversation

Return to Forum