Blackguard Shado-Pan quests not achieving

Bug Report
I have had trouble for some time now with the quests for the Blackguard Defenders division of the Shado-Pan. For some reason, doing the dailies isn't registering for the achievements "A Loner and a Rebel" (who you do the quests without accompaniment) and the "Getting Around with the Shado-Pan" achievement (where you do a number of quests using specific companions.

For the last three weeks, when I do the Blackguard Defenders quests, I have been using Protector Yi as my companion. I have used him four or five times to the end of the quest chain, but he still has not been checked off for the achievement; since you are supposed to do 15 quests with him, and there are 5 quests for day, that should mean that you only need to pick him three times if you keep him with you. I do, yet he is still not checked off.

Today, when I picked up the missions, I also took the Monk companion, Lao-Chin the Iron Belly. However, as soon as I picked him up, I dismissed him in order to try for the solo achievement. I did all the quests, returning to the Shado-Pan camp to pick up the last quest. When I turned that in as well, I did not get the achievement for doing the quests solo.

What gives?
Be sure you dismount before turning in ANY of the dailies for the Shado-pan if you're attempting an achievement with them. Even then they'll sometimes bug and not give you proper credit... I ran into that with the npc required achievement... So if in doubt, turn all the quests in back at camp and be sure you are dismounted prior to interaction with said npc.
Addendum: So I get the Blackguard set of quests again, I do it fully solo, I dismount when turning it in... achievement!

A day or two later, I get the Blackguard quests again. I take Protector Yin, do the quests, then dismount before the final turn-in... achievement progress made!

Making sure that I was standing on the ground for the final turn-in... I don't know why it is different for the Blackguard group, or whether I had been lucky all the previous times I did it, but it works now. Thanks for the help.

Join the Conversation

Return to Forum