Lesson of the Burning Scroll problem

Monk
Have tried two different Priest Pandarens and in both cases, get to this quest and can't "snatch the master's flame". It just sits there and sparkles. No one is around taking the flame. Nothing. I've created two other characters both monks and they worked fine. Priest...not so much. Any ideas?
If you move your cursor all around him, the hand never shows up? Zoom your camera in all the way, perhaps?

CHange your camera angle as well.

I have not rolled anything but a pandaren monk, so I cannot speak to it being a class issue.
Makes no difference, no matter how close of far away the characters are from the flame, they cannot access it. Frustrated beyond belief.
I'm curious as to why this was posted in the Monk forum.

Well, you came to the right place, because I know the answer! Currently there's an issue that causes the interaction point for the flame to be somewhere above "the master's" right shoulder, as screwy as that is (your left side, as you face him). Move your mouse around there until the cursor changes to a "grabbing" hand, then you can interact and "snatch" the flame.

Good luck!
I had that problem on the priest i made the other day too. I also can't find where to get the lvl 20 SFK weapon quest.
Sorry about posting in the Monk forum...I just think of the Pandarens as Monks...my bad. However, I finally got the thing to work, but I had to go into the entryway and then the cursor turned into a "hand" and I could collect the flame. Weird, but after 10 or 20 times of abandoning and retrying the quest, I finally made it through.

Thanks for everyone's help.
that had me stumped for a little while as well. Just need to put the cursor higher over the lamp rather then the hand to get it to work.

Join the Conversation

Return to Forum