Does video recording work for anyone?

Mac Technical Support
And if so, what's your client, comp, and OS?
works fine for me. although you either have to use 32 bit client, or use 64 bit client with the cvar to enable experimental 64 bit recording noted in "known issues" sticky
I've tried both. The 32-bit no longer records correctly; it's garbled. Likewise the 64-bit client with the cvar enabled. Can I ask what OS you're running? I'm still on 10.7.5. You're probably up to 10.8.x, aren't ya?
I'm using 10.8.2 and it works for me.

Try going into the file and deleting all SET lines with "Movie" in them.

Them dig deeper into that folder and find any files and check them for Movie CVars.

Then try recording.
I'm using 10.7.5. Known bugs thread mentions 10.6.8, but not 10.7.5.

Tried what you mentioned. No luck.

Tried removing Cache, Interface, and WTF folders. No luck.

Tried launching from Launcher, using 32-bit client after clearing all game data. No luck.

Added 64-bit line to, tried opening 64-bit client from launcher (otherwise clean CIW folders). No luck.

Getting the game DVD... Back later.
Fresh install, 32-bit client. Doesn't work. Neither does 64-bit. At this point I'm going to assume the movie recording is using something that works properly on 10.8 but dies horribly on 10.7. Playing around with graphics settings and movie settings doesn't change anything either.

Next up: finding $20 to upgrade to 10.8. Back in a few days, or weeks.
FWIW I'm on 10.8.2 and movie recording doesn't work for me either. I mean it records, but gets the blocky colored garbled thing going on. The sound records fine though, it's just a video thing.
How does it work on 5.2 PTR? Is it resolved there?
Yeah, $20 to Apple later, it's still corrupted. I'm working on installing 5.2 now.

Just for kicks, here's what I'm working with:

Hardware Overview:

Model Name: iMac
Model Identifier: iMac11,3
Processor Name: Intel Core i7
Processor Speed: 2.93 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 12 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: IM112.0057.B01
SMC Version (system): 1.59f2

ATI Radeon HD 5750:

Chipset Model: ATI Radeon HD 5750
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x68a1
Revision ID: 0x0000
ROM Revision: 113-B9710C-238
EFI Driver Version: 01.00.417
Display Type: LCD
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

The frustrating part is that this has worked flawlessly for me since its release up until MOP. I actually have some movies recorded during the MOP beta that work correctly. But on live I'm getting the blocky (usually pink) corruption.
01/26/2013 03:56 PMPosted by Omegal
How does it work on 5.2 PTR? Is it resolved there?

There is hope! It works correctly on the PTR! I only hope that whatever the difference is makes it to live!
Let us if it works in the PTR. There has been some changes that should help with movie recording.

There is also a known issue with the PTR 64-bit movie recording:

  • [Mac, Retina, 64-bit] Movie Recordings are corrupt when recording at the highest available Retina Resolution.
It does work on the PTR. Yay!

I don't have a Retina display. (Does the higher dpi actually make a difference to code? O.o) I play at 2560x1440, but I don't have the HDD write capacity to record at that anyway; I usually record at half that.
Azreluna can you check if there's any Cvar differences in or between Live and the PTR that you think could be affecting the recording ?

Be sure to make back up copies of any files you decide to play around in (eg taking cvars from the PTR and trying them out in Live)
Yeah, it's not the Cvars.

I opened both files up. (Not only did config-cache not have anything related to movies or graphics settings, but those appear to be char-specific settings.) I deleted each item that was in both of them. I was left with random things like showNewbieTips and questLogCollapseFilter. I did come across a SET Multisampling "4" line, which seemed to duplicate SET gxMultisample, but deleting that had no effect. I tried copying the movie recording settings from the PTR to the live config file, but that didn't change anything. Keep in mind that earlier on I had tried recording after deleting the entire WTF folder, and that still didn't work.

I'm going to hope that whatever changes Machkan is referring to fix the problem come 5.2.
I'm back.

5.2 is here, and it's still not working. It also no longer works on the PTR client, either. I have no idea whether it's a corrupt WoW install, a corrupt system file somewhere, or a bug in a video driver or other software or something. I've again tried everything short of a reinstall, including using default settings and deleting the holy triad of WoW folders.

I've noticed a few things.

1. Whatever's happening on the WoW screen seems completely unrelated to the garbage that comes out. The end "movie" that's spit out typically alternates between two unchanging frames. That is, the movie is frame A and frame B, neither of which change, despite the fact that there *should* be some sort of difference because the scene in WoW changes. The end movie is ABABABABABABABAB (where both A and B are garbage) at 30 frames per second.

2. Screen elements from outside the WoW screen sometimes show up. I tried recording a movie in windowed mode instead of fullscreen at one point, and I clearly had the icon and label for TextWrangler show up as part of the garbled mess of a movie.

Again, this started happening at MoP's release, which I think is when we got the "better" fullscreen mode. Is there any way to get the old fullscreen back where you had to Cmd-M to switch out of the program?

After my raid tonight I think I'm going to try reinstalling again. : \
I am sorry, I did not search for new threads before I posted to an old one. The thread I have been tracking for this issue is this one:

But anyway, I am running 10.8.2 on 2010 iMac and it appears movie recording works (in both clients) but changing settings may cause the old blocky videos. This is based on my quick short video testing. More detailed testing coming over the weekend during raid.

If someone does read this, please point to or use this post as the current information thread (last time I checked there are about 5 threads on movie problems). Thanks.
I am also having this issue a year later(now) on my New Mac Pro with 10.9.2 installed.

Join the Conversation

Return to Forum