Command+m reloads WoW

Mac Technical Support
So instead of just minimizing WoW it also reloads, meaning all of chat is cleared so when people are talking about something and i go to look it up, what ever they said when i fullscreen it again, its gone, is there a fix for this?
It's a known issue and will be fixed in a future client side patch when said fix is ready.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Thanks for the info, it didn't say anything in the known bugs and issues, and im new to Macs, i wasn't sure if it was on my side or not
was also curious (annoyed) about this. thanks for the info!
This should be in our known issues sticky already.

  • Switching display modes (Command-M or in-game settings) may cause the UI to reload.
I get around this with shift-tab. It moves me back and forth between my WoW app and my finder. Easy-peasy.
01/09/2013 11:01 AMPosted by Solembum
I get around this with shift-tab. It moves me back and forth between my WoW app and my finder. Easy-peasy.


I just gave this a try. It's faster too. I've been using the command M method for years but this is plain faster. I don't care to see or play wow in window mode, I just want to switch apps and this seems to be a great solution.
01/09/2013 11:01 AMPosted by Solembum
get around this with shift-tab. It moves me back and forth between my WoW app and my finder. Easy-peasy.


Just commenting on what solved the problem for me. For years I've always used cmd + M and never had the reload issue. Today I used cmd +M then manually resized the window to be smaller by dragging the bottom right corner as I needed to see my web browser better. When I hit cmd +M again to return to full screen, the game reloaded and cleared chat. This kept happening every subsequent time I hit [cmd + M] despite a full restart and cache clear. My guess is that by resizing it manually I somehow triggered something that made the UI want to reload each time?

I tried what was mentioned above (hitting Tab + Shfit) and now when I click [cmd + M], the UI no longer reloads. Not sure how or why it worked but it basically put everything back to the way it was for me.
01/09/2013 11:01 AMPosted by Solembum
I get around this with shift-tab. It moves me back and forth between my WoW app and my finder. Easy-peasy.


You mean Command-tab right? Because Shift-Tab doesn't do anything for me.
Does this still happen if you go into graphics/advanced then enable "Ui scale" and set it to 1.0? I have a feeling the reload is being caused by a change in interface scale only, which is why it can be avoided if the scale respects an aspect ratio and doesn't change when window size does. I know I use command-m like 30 times a day without issue but i always force a 1.0 aspect ratio preserving of UIscale (to avoid the annoying UI resizing when window size shifts from toggling command - m)
This has been happening to me too. I did the same thing Kinetic did, only by accident. I used Command M to look something up online, and I accidentally changed the size of the WoW window. Now whenever I use Command M, it reloads the AI instead of just minimizing the window. Not sure how to get back to the way it was before. I checked the UI Scale per Omegal's suggestion, but my scale is already set to 1.0. Any ideas how to keep Command M from reloading AI every time?? Thanks!
Here's an update. I figured since resizing the screen starting caused Command+M to reload the AI, I would resize the screen again. And it worked! Command+M is working the way it used to. Let me know if you have any questions :)
02/23/2013 04:31 PMPosted by Alindrios
Here's an update. I figured since resizing the screen starting caused Command+M to reload the AI, I would resize the screen again. And it worked! Command+M is working the way it used to. Let me know if you have any questions :)

interesting. i wonder then if the issue is purely about window aspect ratio matching in windowed vs fullscreen mode. I thought it was ui scale but ratio is a slightly different thing
Having the same issue and changing the Ui scale didnt work work for me. I will however be using the command tab thank you for that heads up. Still cant use the command m tho. :0(
I just posted this in another thread but I figured I would add it here since it has more attention.

I have had this problem in the past. I solved it by setting the resolution to something different when in windowed mode and then back to whatever I had it on before. This fixed the loading and the switching to 4:3 aspect in windowed mode. Specifically:

1. Switch to windowed mode (Command + M), wait for the loading screen.
2. Open the graphics settings.
3. Note what Resolution you're set to currently.
4. Set Resolution down one step (maybe to anything else, down one is just what I did which worked) and click [Apply].
5. It should be in the correct aspect ratio now, and at the expected resolution (though the window might still be smaller than that since it can scale). Set it back to your original or desired resolution at this point and click [Apply] again.
6. Command + M at will to verify the issue is resolved.

That fixed it for me, seemingly permanently.

If you don't actually need to be in windowed mode but still need to access other apps with WoW running you can always use Command + H to hide WoW or Command + Tab to switch apps. That should work around the problem even if you don't do the above.
So it seems to be like a bug... It's the most annoying buy in the WoW Mac History. It started to happen after the latest Patch. It's annoying me to the fullest, especially it reloads the chat as well...

Overall the Patch is very unstable to me. WoW crashes for no reason. Either in the login screen or just in the game in general. There is no pattern to see when it's happening. I do a lot of arenas..

It seems to happening when you play WoW minimized with two screens and if you do some web browsing or so and then WoW crashes. But not always either.. so I'm not sure what's the problem is. It pisses me off a lot..
I just posted this in another thread but I figured I would add it here since it has more attention.

I have had this problem in the past. I solved it by setting the resolution to something different when in windowed mode and then back to whatever I had it on before. This fixed the loading and the switching to 4:3 aspect in windowed mode. Specifically:

1. Switch to windowed mode (Command + M), wait for the loading screen.
2. Open the graphics settings.
3. Note what Resolution you're set to currently.
4. Set Resolution down one step (maybe to anything else, down one is just what I did which worked) and click [Apply].
5. It should be in the correct aspect ratio now, and at the expected resolution (though the window might still be smaller than that since it can scale). Set it back to your original or desired resolution at this point and click [Apply] again.
6. Command + M at will to verify the issue is resolved.

That fixed it for me, seemingly permanently.

If you don't actually need to be in windowed mode but still need to access other apps with WoW running you can always use Command + H to hide WoW or Command + Tab to switch apps. That should work around the problem even if you don't do the above.


I was having this trouble as well, but this worked perfectly! Thank you. :)
01/03/2014 10:35 AMPosted by Inarasera
I just posted this in another thread but I figured I would add it here since it has more attention.

I have had this problem in the past. I solved it by setting the resolution to something different when in windowed mode and then back to whatever I had it on before. This fixed the loading and the switching to 4:3 aspect in windowed mode. Specifically:

1. Switch to windowed mode (Command + M), wait for the loading screen.
2. Open the graphics settings.
3. Note what Resolution you're set to currently.
4. Set Resolution down one step (maybe to anything else, down one is just what I did which worked) and click [Apply].
5. It should be in the correct aspect ratio now, and at the expected resolution (though the window might still be smaller than that since it can scale). Set it back to your original or desired resolution at this point and click [Apply] again.
6. Command + M at will to verify the issue is resolved.

That fixed it for me, seemingly permanently.

If you don't actually need to be in windowed mode but still need to access other apps with WoW running you can always use Command + H to hide WoW or Command + Tab to switch apps. That should work around the problem even if you don't do the above.


Bless you! That worked perfectly!
01/03/2014 10:35 AMPosted by Inarasera
I just posted this in another thread but I figured I would add it here since it has more attention.

I have had this problem in the past. I solved it by setting the resolution to something different when in windowed mode and then back to whatever I had it on before. This fixed the loading and the switching to 4:3 aspect in windowed mode. Specifically:

1. Switch to windowed mode (Command + M), wait for the loading screen.
2. Open the graphics settings.
3. Note what Resolution you're set to currently.
4. Set Resolution down one step (maybe to anything else, down one is just what I did which worked) and click [Apply].
5. It should be in the correct aspect ratio now, and at the expected resolution (though the window might still be smaller than that since it can scale). Set it back to your original or desired resolution at this point and click [Apply] again.
6. Command + M at will to verify the issue is resolved.

That fixed it for me, seemingly permanently.

If you don't actually need to be in windowed mode but still need to access other apps with WoW running you can always use Command + H to hide WoW or Command + Tab to switch apps. That should work around the problem even if you don't do the above.


oh bless your soul! I was so annoyed with this issue and you completely solved it
11/25/2014 01:13 PMPosted by Tinkertoots
[quote="110389016582"]I just posted this in another thread but I figured I would add it here since it has more attention.

I have had this problem in the past. I solved it by setting the resolution to something different when in windowed mode and then back to whatever I had it on before. This fixed the loading and the switching to 4:3 aspect in windowed mode. Specifically:

1. Switch to windowed mode (Command + M), wait for the loading screen.
2. Open the graphics settings.
3. Note what Resolution you're set to currently.
4. Set Resolution down one step (maybe to anything else, down one is just what I did which worked) and click [Apply].
5. It should be in the correct aspect ratio now, and at the expected resolution (though the window might still be smaller than that since it can scale). Set it back to your original or desired resolution at this point and click [Apply] again.
6. Command + M at will to verify the issue is resolved.

That fixed it for me, seemingly permanently.

If you don't actually need to be in windowed mode but still need to access other apps with WoW running you can always use Command + H to hide WoW or Command + Tab to switch apps. That should work around the problem even if you don't do the above.


oh bless your soul! I was so annoyed with this issue and you completely solved it[/quote

Sorry to bump an old thread but I was having this issue tonight and this solved my problem. Thank you.

Join the Conversation

Return to Forum