[FORUM ISSUE] Can't change to "Polara"

Website Bug Report
For some reason, on the forums, it won't let me switch my posting character to Polara@Wyrmrest Accord.

I can switch to any other of my characters, except her.

I have tried 2 different browsers on my Mac (Firefox, Safari), and my iPhone's Safari (which is even a different ISP). No dice, still hangs when trying to access Polara, so this does not seem like a cache issue (in fact, my Mac's Safari, which uses a different cache file than Firefox, hadn't ever browsed the forums until now)

Any help would be appreciated. Thanks.
Resolved.. not sure what happened but it works now. :)
I am having a similar issue. I can log into any of my toons except 2. My 2 mains. go figure.

I cannot change to "DLM" or "OPHA"

I have tried internet explorer, chrome and firefox. All browsers are up to date on my win7 pc which is up to date as well.
Okay so today I can switch to this char, but its still a no go on my main toon "DLM"

Join the Conversation

Return to Forum