Retina MacbookPro FPS issues been solved yet?

Mac Technical Support
Hello,

It's been quite a while now that the latest Retina Macbook Pro laptops are having trouble with FPS/performance issues. Are they solved yet? or do we still have no choice but for WoW tech team to respond? and I know even for some people (including myself) SMC reset doesn't even work.

Thank you.
This is something that still hasn't been able to be reproduced for Retina MacBook Pros from the Mac team's testing. If the team is unable to reproduce the issues, then fixes/updates cannot be applied.

Can you describe what kind of symptoms you are having, specific frame rate settings and your system specs?

    1. Launch World of Warcraft and log in.
    2. Put World of Warcraft into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information: http://i45.tinypic.com/foodww.png
    4. Paste the contents of the copied system information here (Command-V)
Software:

System Software Overview:

System Version: OS X 10.8.2 (12C3006)
Kernel Version: Darwin 12.2.1
Time since boot: 2 days 7:53

Hardware:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.7 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32

Graphics/Displays:

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Displays:
Color LCD:
Display Type: LCD
Resolution: 2880 X 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI
I have both a MacBook Pro Retina 13 and 15 inch. The 15 inch is the one with the issues, for whatever reason. I have been getting around 13-15 FPS, with the exception of when I did an Arathi Basin, where I had 30 fps consistently.
Have you tried to do the SMC reset? A lot of users who have the 15" retina had issues after the EFI update post 10.8.2. Resetting the SMC seems to resolve the issues for the time being.

Join the Conversation

Return to Forum